FRDM-K64F Startup problems

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM-K64F Startup problems

844 Views
Senior Contributor II

Hi, I'm trying to get started with the FRDM-K64F board.

I've played with mbed; but would prefer to just use cygwin/gcc and build the apps that come with the SDK.

 

So, I unzipped the sdk, and cd'd to apps/hello_world/gcc/frdmk64f120m .  I adjusted the common.mk file

(at the top directory level) to point to my arm-none-eabi-gcc.  When I typed make, I get an error like this:

 

arm-none-eabi-gcc.exe: error: /cygdrive/c/users/ed/documents/KinetisK64/Kinetis_SDK/KSDK_1.0.0-Beta/apps/hello_world/src/hello_world.c: No such file or directory

 

Of course, the file does exist but (I've seen this before) apparently arm-none-eabi-gcc.exe doesn't understand the "/cygdrive/c" path which is created by abspath in the makefile.

So, I tried to hard-code the path to use C:/ instead of /cygdrive/c, then 'make' complains with this error:

 

c:/users/ed/documents/KinetisK64/Kinetis_SDK/KSDK_1.0.0-Beta/mk/targets.mk:149: *** target pattern contains no '%'.

 

Googling a bit, I found that newer versions of make don't like the colon in the path, so the recommendation (according to

stackoverflow) was to use make version 3.8.  So I build it and replace my current make (which was GNU Make 4.0).

Then when I run with that version of make, its apparently so old that it doesn't recognize "else ifeq" in some of the other

  1. makefiles.  Arrgghh!

 

I must be doing something wrong here right?  Has anyone built the SDK apps using cygwin/gcc?

Tx

Ed

Labels (1)
0 Kudos
3 Replies

52 Views
Senior Contributor II

Self-reply here...

I posted this several days ago, with no response, and eventually realized I had it posted in the wrong discussion group.  Anyway, I wanted to keep this post, so it is re-posted here (hopefully in the right place now).  Meanwhile I gave up on trying to build the SDK directly from the included makefiles, and started up my own build that simply uses CodeSourcery, make, a FRDM-K64F and the Segger OpenSDAv2 bootloader.  This works very nice... I run "make" followed by "make flash" and its installed onboard.

Anyway, I'm still plugging away at snippets of the SDK code.  I've basically just taken various files from the SDK to build my program.  The biggest (time consumption) hurdle to get started was the fact that I had to define  __NO_INIT_DATA_BSS when compiling startup_MK64F12.S.  Nevertheless; I would still like to know if folks have built the SDK (using gcc-tools on pc/cygwin) successfully.

Thanks

0 Kudos

52 Views
NXP Employee
NXP Employee

Hi Ed,

I was able to build SDK succesfully with GCC followig the instructions in Kinetis SDK K64 User's Guide on KSDK installation folder.

Did you added the necessary environment variables indicated on section "4.2 GCC ARM Embedded Tool"  in Windows? Please be aware that you must compile first the library to be able to build the examples.

Regards,

Carlos

0 Kudos

52 Views
Senior Contributor II

Carlos,

Hi, thanks for replying.  Yea, I followed (almost) those steps, but get the error described above.

The one difference in my environment is that I'm just running with Cygwin, not MINGW.

There's apparently some fundamental environment difference between the two which causes the issue

I describe above.  Its possible I just have something screwed up in my Cygwin environment; however,

I've cross-compiled like this for years without problems; so I think its just some difference between

Cygwin and MINGW (haven't used the latter very much).

Anyway, its not a big deal anymore, I've managed to pull together my own environment (using Cygwin)

to build up my boot monitor (http://www.umonfw.com) for the K64FRDM board.

Thanks again,

Ed

0 Kudos