Help with the "Debug Database Initialization" message?

cancel
Showing results for 
Search instead for 
Did you mean: 

Help with the "Debug Database Initialization" message?

794 Views
Contributor I

Hello, I just installed CodeWarrior for MCU's in a laptop with Windows 10 (64 bit architecture) and at the moment I opened CodeWarrior I got the following message: "An internal error occurred during: Debug Database Initialization. java.lang.ExceptionInInitializerError". I tried removing the .metadata folder and also re-installing CodeWarrior but it didn't work. Any suggestions anybody? I would really appreciate it. I also attached the diagnostics file if it can be of any help.

 

Best regards!

Original Attachment has been moved to: 201609061259_DiagnosticInfo.zip

Labels (1)
4 Replies

237 Views
Contributor II

In case it helps...

I had a similar issue (same error) when I installed CodeWarrior 10.2 onto a Windows 7 x64 PC.

In your workspace directory, under .metadata there is a log file with no name (just called ".log")

In that file I had the following error reported:

java.lang.UnsatisfiedLinkError: C:\Freescale\CW MCU v10.2\eclipse\plugins\com.freescale.core.debugger.ddd_7.18.0.FSL_b10910\DebugDatabase.dll: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail

Side-by-side loading usually means that it expected something else to have been installed that is relied on.

I had to install the "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)" - NOTE its the 32bit package, which can be downloaded from Microsoft here:

Download Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) from Official Microsoft Downloa... 

Once that was installed and I then restarted CodeWarrior the issue is no longer reported.

Hope it helps!

Phil

160 Views
Contributor III

Hello Phil,

many thanks. I had the same problem  after installing CW 11V1. After downloading the  "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)" from microsoft and repairing the package that was installed with CW, everything worked fine.

 

Thanks again.

 

Regards,

John

0 Kudos

237 Views
Contributor IV

Hello,

Thank you a lot Phil, I cannot tell you how happy I am now with your solution..

I was getting the "cannot load debug database" error and also "Unknown Target Type" error and my "Target Types" list was empty. 

This solved my error, I have un-installed all the Microsoft Visual C++ Redistributable Package versions and re-installed all the versions for both x86 and x64 and this worked!

Thank you again, thank you..

--

Abdullah

0 Kudos

237 Views
NXP Employee
NXP Employee

Hello Javier

Are you logging on Windows with Administrator right?  Could you please install the CodeWarrior under the default path?

C:\Freescale\CW MCU v10.7


Best Regards
Fiona Kuang
TIC - Technical Information Center
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Mark Correct button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos