T1040: Core not respoding. Starting IR Scan test ... Error measuring IR length

cancel
Showing results for 
Search instead for 
Did you mean: 

T1040: Core not respoding. Starting IR Scan test ... Error measuring IR length

58 Views
Contributor IV

Hello community,

We have two Code Warrior TABs. We have a custom design based on T1042 processor. Until now, we were able to debug/run in our custom board using code warrior. We were succesfully writing to flash or do something else on board. 

Code warrior tab has started to give "T1040: Core not responding error".

We believe that we have a valid rcw on the boards flash because we can successfully execute bootloader. Then we realised that same error is occuring on T1042D4RDB demo board. The same error is also occurs with other Code Warrior tab we have. We also tried with changing CHW-CTP-COP-YE (30 - 16 jtag pin connector) between each other. Nothing changed

What is the reason of this situation ?

Error Log from CW IDE:

JTAG Diagnostics

Starting Power at Probe test ...
Test result: PASSED

Starting IR Scan test ...
Error measuring IR length
ccs_jtag_unlock
serverh = 0
cc = 0
ccs_jtag_unlock; ccs_error = 0
ccs_config_chain
serverh = 0
cc = 0
device_list: (size = 1)
device[0]:: core_type=T1040(237)
ccs_config_chain; ccs_error = 39
Error message: T1040: Core not responding
ccs_get_subcore_error
serverh = 0
cc = 0
error = 5
chain_pos = 0
ccs_get_subcore_error; ccs_error = 0; duration=1 ms
ccs_kill_server
serverh = 0
ccs_kill_server; ccs_error = 0

Labels (1)
0 Kudos
1 Reply

16 Views
NXP TechSupport
NXP TechSupport

Hello Yusuf Altıparmak,

According to your description, it seems that there is problem with CodeWarrior TAP.

Please plug off USB cable from CodeWarrior TAP and plug in the cable to the TAP again to check whether CodeWarrior TAP works normally.

Thanks,

Yiping

0 Kudos