Linker errors with QN9080 SDK examples under MCUXpresso IDE v11.0.0

cancel
Showing results for 
Search instead for 
Did you mean: 

Linker errors with QN9080 SDK examples under MCUXpresso IDE v11.0.0

lpcxpresso_supp
NXP Employee
NXP Employee
1 0 518

When using the QN9080 with SDK v2.2 2019-01-29, or earlier, there is an issue in the SDK internal data which can lead to MCUXpresso IDE v11.0.0 failing to set consistent floating point options when importing multiple examples. This issue can lead to linker errors when example projects are built relating to "VFP register arguments": 

 

pastedImage_1.png

This issue will be resolved in a future release of the QN9080 SDK. But with the current QN9080 SDK, then to avoid this issue, you can:

  • Import example projects individually, or
  • Before importing the projects, go to:
    • Window -> Preferences -> MCUXpresso IDE -> SDK Handling -> Misc

and untick the "Enable SDK options check" option:

 

pastedImage_1.png

 

Notes :  

  • Turning this option off is not generally recommended.
  • On macOS, the Preferences dialog is available from the "MCUXpresso IDE" menu entry rather than "Window".

 

Alternatively to fix projects that you have already imported that are generating linker errors relating to "VFP register arguments", then

  • Select the project(s) in the Project Explorer View
  • Then select Quickstart Panel -> Quick Settings -> Set Floating Point type -> FPv4-SP (Hard ABI)

 

pastedImage_2.png