ecompass_cm7 sample project cannot see FXOS8700 on MIMXRT1170-EVK board

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

ecompass_cm7 sample project cannot see FXOS8700 on MIMXRT1170-EVK board

跳至解决方案
364 次查看
kchan
Contributor II

The development PC is Windows 10 Enterprise 21H2.

The IDE is MCUXpresso v11.7.0.

The SDK installed in the IDE is SDK_2.13.0_MIMXRT1170-EVK.

I disconnected J6 and J7 on the eval board and connected Segger JLink to J1.

I connected a USB cable from my development PC to J11 on the eval board.

 

I imported the SDK project ecompass_cm7, under the demo_apps category, and configured the debugger to use JLink to flash the board.  I started the debugger, which stopped at the first line of main() in ecompass.c.  I used the IDE terminal to connect to the USB serial port on the eval board.

I then resumed program execute and observed this print statement showing "Sensor device initialize failed!"

I stopped the debugger and repeated the debug process...it showed the same print statement.

I then imported the MQX accel sample project into the IDE and tried that one.  The terminal tab showed print statements:

Checking I2C 1, device 0x1c...no response
Checking I2C 1, device 0x1d...no response
Checking I2C 1, device 0x1e...no response
Checking I2C 1, device 0x1f...no response
Checking I2C 1, device 0x20...no response

No accelerometer found.

 

I am submitting a picture of the eval board showing my usb to serial and jlink connections.

Thank you in advance for your help!

 

标记 (3)
0 项奖励
1 解答
352 次查看
Masmiseim
Senior Contributor I

Hello,

 

as you can see in your picture, the Sensor FXOS8700CQ is not soldered on your board.

So, it is no surprise that you cannot communicate with it.

 

Regards

在原帖中查看解决方案

0 项奖励
2 回复数
353 次查看
Masmiseim
Senior Contributor I

Hello,

 

as you can see in your picture, the Sensor FXOS8700CQ is not soldered on your board.

So, it is no surprise that you cannot communicate with it.

 

Regards

0 项奖励
350 次查看
kchan
Contributor II

That would explain it.  Thank you!

0 项奖励