USB VCOM Example Failure

取消
显示结果 
搜索替代 
您的意思是: 
已解决

USB VCOM Example Failure

跳至解决方案
813 次查看
jaredm
Contributor III

I'm trying to run the USB VCOM example project on RT1052-based custom hardware. My setup is as follows:

1. Import example project.

2. Remove BOARD_FLASH in linker script. The example fits in 128K internal RAM with ample margin.

3. Modify CONTROLLER_ID to be kUSB_ControllerEhci1. My hardware uses the second USB controller.

4. Compile and run the project.

I can debug the application and step through code.

I've also attached a Beagle USB analyzer. The RT1052 USB controller responds when attached to my PC, but does not ACK the initial SETUP/DATA0 request. I've attached a trace from the Beagle. You can see the ACK is missing after SETUP/DATA0. When I unplug/replug the USB cable, the RT1052 attempts to re-initialize the USB stack and the same problem occurs. (Demonstrates that the USB stack is not frozen, and the problem is repeatable.)

Does anyone have ideas as to what might be wrong?

标签 (1)
0 项奖励
1 解答
805 次查看
jingpan
NXP TechSupport
NXP TechSupport

Hi jaredm,

Could it be a hardware problem? I test on my EVB. It works fine.

 

Regards,

Jing

在原帖中查看解决方案

0 项奖励
2 回复数
806 次查看
jingpan
NXP TechSupport
NXP TechSupport

Hi jaredm,

Could it be a hardware problem? I test on my EVB. It works fine.

 

Regards,

Jing

0 项奖励
794 次查看
jaredm
Contributor III

Hi Jing,

You are correct, it was a hardware problem.

On my board, I have a 5-pin header for GND, D-, D+, ID, and 5V0. Since I do not have a test fixture yet, I soldered a USB cable directly to the PCB for testing. Unfortunately, I mixed up the D- and D+ wires. After I soldered the D- and D+ wires to the correct locations, the example worked perfectly.

Thanks for the suggestion!

jaredm

0 项奖励