IMXRT1020 debug with LPC link 2

cancel
Showing results for 
Search instead for 
Did you mean: 

IMXRT1020 debug with LPC link 2

75 Views
Irv95G
Contributor II

hi, 

im using the MIMxrt1020-EVK and MCUXpresso, im trying to debug it using the LPC link 2 but i get this error : Target rejected debug access at location 0x2000A2E4.

am i missing some cofiguration on the Evaluation board ? 

debbuging.PNG

Thanks, 

0 Kudos
5 Replies

69 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @Irv95G ,

  Do you mean, you are using the external LPC-LINK2 in stead of the on board CMSIS DAP debugger?

  If you are using the external debugger, you need to disconnect the on board debugger, J47-J50.

Then connect your external LPC-LINK2 to the j16 jtag port, in your MCUXpresso, please also press shift+debug button, to recognize the external debugger again.  Or you can delete the .launch file, then click debug button again.

 

Wish it helps you!

Best Regards,

Kerry

 

0 Kudos

64 Views
Irv95G
Contributor II

hi @kerryzhou 

Thanks for the information. 

i forgot to mention tha i want to get debug over the 10 pin JTAG(J29), 

i'm stalling the CMSIS-DAP firmware on the LPC-Link2, 

i disconnect the on board debugger (J27 - J28) on xrt1020

i press th debug button and select the probe and im still getting the same error.  

0 Kudos

59 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @Irv95G ,

 Please take a photo of your board connection, and send it to me.

Best Regards,

kerry

0 Kudos

45 Views
Irv95G
Contributor II

hi @kerryzhou 

thanks for your help, i realized the problem... i was using the wrong JTAG header J29  instead of J16. 

0 Kudos

34 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @Irv95G ,

 Ok, thanks for your updated information.

So, if your issue is solved, please help to mark the correct answer, just to close this case.

Any new issues, welcome to create the new case.

Best Regards,

Kerry

0 Kudos