Debugging sessions suspended unexpectedly when using semihost

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

Debugging sessions suspended unexpectedly when using semihost

522 次查看
gtalocchino
Contributor II

Hello everyone,

We are experiencing a very annoying problem when debugging using MCUXpresso with the iMX RT1020 and semihost to redirect printf.

It happens that suddenly and totally unexpectedly the debugger session is suspended in the PIT ISR. It always suspends in the same place (PIT ISR) even without setting any breakpoints and selecting "Skip All Breakpoints" in the IDE. We are using PEmicro probes.

It is very annoying and it is preventing us from debugging since the sessions are suspended unexpectedly and we must give it "Resume (F8)" manually.

We have no idea what is going on and what we can do to fix this.

Here is an image of the Call Stack when it happens

Call stack when suspension occurs.Call stack when suspension occurs.

I hope you can help us.

标签 (1)
0 项奖励
3 回复数

491 次查看
Hui_Ma
NXP TechSupport
NXP TechSupport

Hi,

Do you have MIMXRT1020-EVK on hand? In default, the RT1020 EVK board is using CMSIS DAP debugger tool.

What's the MCUXpresso IDE version you are using? The latest version is V11.6.1.

Mike

0 项奖励

481 次查看
gtalocchino
Contributor II

We are using a custom board with PEmicro probes. Currently using  MCUXpresso v11.5.1.

Do you think the SIGTRAP raised when PIT interrupt semihost printf is an IDE problem?

0 项奖励

476 次查看
Hui_Ma
NXP TechSupport
NXP TechSupport

Hi,

I find using semihost printf with RT1020 EVK board on board CMSIS DAP works normally.

The print message was showing during the debug phase:

Hui_Ma_1-1666860898820.png

While switch  to P&E Multilink Universal FX debugger during debug phase without any print message at console. After terminated the debug, those print messages were showed:

Hui_Ma_0-1666860728778.png

 Mike

0 项奖励