Update MDK to 5.30, an err "RTE_Components.h not found"

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

Update MDK to 5.30, an err "RTE_Components.h not found"

4,378 次查看
zhangyunfeng1
Contributor I

I have update my mdk compiler to V5.30, an err "RTE_Components.h not found" print out when compile SDK 2.7.0 version with MIMXRT1064

标签 (1)
0 项奖励
回复
3 回复数

3,959 次查看
banxian
Contributor I

I recently meet the same bug. but I think it's not bug of AC6,

after some research, I found the -D_RTE_ define is imported during depends parsing step.

but in entire SDK_2.8.2_EVK-MIMXRT1010 folder, there was only $ifdef check, I can't found the source of _RTE_.

0 项奖励
回复

4,239 次查看
jeremyzhou
NXP Employee
NXP Employee

Hi Yunfeng Zhang ,

Thank you for your interest in NXP Semiconductor products and
for the opportunity to serve you.
Actually, I've no idea about this error, so I was wondering if you can describe the steps of replicating the issue.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 项奖励
回复

4,239 次查看
thoomanwang
Contributor V

This error is caused by AC6 not recognizing # ifDEF _RTE_. It can be solved by changing the code:

# ifdef _RTE_

# include "RTE_Components. H"

# endif

Instead of

# ifdef _RTE_

/ * # include "RTE_Components. H" * /

# endif