Display examples on SDK_2_10_0 not working

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Display examples on SDK_2_10_0 not working

874 Views
abele_barbieri
Contributor I

Hi,
I found this issue using the MIMXRT1050-EVK  with RK043FN02H-CT display (see terminal captured image here below)
The EVK board don't show images and program is not working

abele_barbieri_2-1637065955616.png
I'm trying the sample evkbimxrt1050_ew_gui_smart_thermostat from SDK_2_10_0_EVKB-IMXRT1050, using MCUXpresso IDE v11.4.1_6260.
I checked also with the example on QT https://www.qt.io/microcontrollers-nxp
In this case (as you can see in the photo below) the board works fine. 
Have you any suggest about? Thank you
Abele

qt_sample.jpg

 

 

 

 

0 Kudos
Reply
3 Replies

852 Views
Omar_Anguiano
NXP TechSupport
NXP TechSupport

Hello

Hope you are well.
I programmed the board with the same example using the most recent SDK/IDE version and it worked well.

Omar_Anguiano_1-1637808888594.png

Omar_Anguiano_2-1637808908747.png


Please make sure that the jumpers are in the default position.
Is this problem present in all the ew_gui examples? Did any change was made before loading the example to your board?
Are you using an external debugger or the on-board debugger?

If you have more questions do not hesitate to ask me.
Best regards,
Omar

0 Kudos
Reply

831 Views
abele_barbieri
Contributor I

Hi Omar,
first of all, the sample on your photo seems not same that is on SDK_2_10_0_EVKB-IMXRT1050 I have downloaded from 

abele_barbieri_0-1637834580534.png

About your questions:
- my EVK board is right configured, note that when I tried with QT example this is working well.
- the issue is on all display examples
- no change made on SDK examples, I only build it and download into my EVK board.
- I'm using on-board debugger
In addition, the serial log shows that sample seems start, but it stops into while error.

The same issue you can find in this topic https://community.nxp.com/t5/i-MX-RT/Touch-panel-not-work/m-p/1370755/highlight/false#M17117
In any case, I think I have found the issue.
As on i.MX RT1050 Processor Reference Manual, page 998-999, here below the GPIO registers allowed on RT1050 family

abele_barbieri_1-1637835005694.png

but on evkbimxrt1050_ew_gui_smart_thermostat from SDK_2_10_0_EVKB-IMXRT1050, the IGPIO module is configured to use CLR, SET and TOGGLE register (instead of directly DR register)

abele_barbieri_2-1637835043908.png

I  see that GPIO library is provided for both method

abele_barbieri_3-1637835196331.png

I tried to modify the IGPIO module configuration

abele_barbieri_4-1637835231990.png

and now Termo and all Display examples are working

abele_barbieri_5-1637835251855.png

What you think about?
Thanks for your help

Abele

 

0 Kudos
Reply

827 Views
abele_barbieri
Contributor I

Hi Omar
your sample seems not same as on SDK_2_10_0_EVKB-IMXRT1050 that I have download from NXP 
MCUXpresso SDK - SDK Builder.
For your questions:
- all display samples aren't working
- HW is right configured, note that QT example is working 
- No changes made on source code, I just compile the sample and download it into board
- I'using on-board debugger
Please note that sample starts correctly, but is stops on while with error on serial log and my issue is same as this topic https://community.nxp.com/t5/i-MX-RT/Touch-panel-not-work/m-p/1370755/highlight/false#M17117

In any case, think I have found the issue.
As on i.MX RT1050 Processor Reference Manual, page 998-999, here below the GPIO registers allowed on RT1050 family

abele_barbieri_0-1637828461909.png

 

but on evkbimxrt1050_ew_gui_smart_thermostat from SDK_2_10_0_EVKB-IMXRT1050, the IGPIO module is configured to use CLR, SET and TOGGLE register (instead of directly DR register)

abele_barbieri_1-1637828461921.png

 

I see that GPIO library is provided for both method

abele_barbieri_2-1637828461919.png

 

I tried to modify the IGPIO module configuration

abele_barbieri_3-1637828461923.png

 

and now Termo and all Display examples are working

abele_barbieri_4-1637828461925.png

What you think about?

Thanks for your help.
Abele

 

0 Kudos
Reply