unable to upload to NXP 1170 eval board

取消
显示结果 
搜索替代 
您的意思是: 
已解决

unable to upload to NXP 1170 eval board

跳至解决方案
390 次查看
tomdunigan
Contributor II

I managed to brick my 1170 eval board with bad setting for GPT2 mux in clock_config.c.  I am unable to upload a new program.  Is there a way to erase the QSPI flash,  or some other magic to get around the killer program on the board ?  I have developed many working programs for the 1170, but I am not proficient in the use of the IDE.

I'm on ubuntu linux with MCUXpresso_11.3.1_5262 using USB as debug console (/dev/ttyACM0).    "debug"  fails for cm7 blinky program, with popups saying things like

"O2: failed on connect"

"Failed to execute MI command"

"Error in final launch sequence"

标签 (1)
0 项奖励
1 解答
381 次查看
tomdunigan
Contributor II

OK, reviewing my NXP 1060 notes, I had the same problem with 1060 eval board.  I used GUI Flash Tool to erase flash. 

After a couple of tries with SW2 settings, this worked:

1) power off eval board

2) set SW2-7 to ON

3) power up and from IDE run GUI Flash Tool and select "erase flash" tab, and RUN (took about 25 seconds to erase flash)

4) power down eval board and set SW2-7 back to OFF

5) power up eval board and upload a working program  

在原帖中查看解决方案

0 项奖励
1 回复
382 次查看
tomdunigan
Contributor II

OK, reviewing my NXP 1060 notes, I had the same problem with 1060 eval board.  I used GUI Flash Tool to erase flash. 

After a couple of tries with SW2 settings, this worked:

1) power off eval board

2) set SW2-7 to ON

3) power up and from IDE run GUI Flash Tool and select "erase flash" tab, and RUN (took about 25 seconds to erase flash)

4) power down eval board and set SW2-7 back to OFF

5) power up eval board and upload a working program  

0 项奖励