uboot fails to boot squashfs

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

uboot fails to boot squashfs

跳至解决方案
2,018 次查看
greeran
Contributor III

hi

i created a squashfs rootfs via yocto. i copyied it to the mmc from the SDCard. from the SDCard i can mount the mmc and correctly

#mount -ls  = (/dev/mmcblk2p1 on /run/media/mmcblk2p1 type squashfs (ro,relatime))

when i boot from internal mmc i get 

Production date: 2020 Feb 11
Serial Number: f8:dc:7a:3b:8e:90
switch to partitions #0, OK
mmc2(part 0) is current device
flash target is MMC:2
Net: AR8033 PHY detected at addr 0
eth0: ethernet@30be0000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc2(part 0) is current device
** Unrecognized filesystem type **
** Unrecognized filesystem type **
Error: Bad gzipped data
Booting from net ...

 

what am i doing wrong

thanks

标签 (1)
标记 (1)
0 项奖励
1 解答
1,998 次查看
greeran
Contributor III

hi

i found my problem, i misunderstood the boot sequence. the (current) U-Boot does not support SquashFS so i created a boot partition mmc1part2 with ext4 and added the /boot files. in the boot args i directed the kernel image and the fdt to the ext4 boot and the rootfs to the squash rootfs in another partition.

the boot was successful after that

thanks

 

在原帖中查看解决方案

0 项奖励
3 回复数
1,999 次查看
greeran
Contributor III

hi

i found my problem, i misunderstood the boot sequence. the (current) U-Boot does not support SquashFS so i created a boot partition mmc1part2 with ext4 and added the /boot files. in the boot args i directed the kernel image and the fdt to the ext4 boot and the rootfs to the squash rootfs in another partition.

the boot was successful after that

thanks

 

0 项奖励
2,012 次查看
dvlogic
Contributor III

Hi,

I think you need to enable this option in your uboot defconfig:

CONFIG_FS_SQUASHFS=y
 
My system uses a squashfs with a overlay and I'm able to boot successfully from the squashfs.
 
-- d

 

0 项奖励
2,000 次查看
greeran
Contributor III

hi

i tried to add the squashfs to the uboot but it does not have an option for squash. this are the options that i see

# Filesystem commands
#
# CONFIG_CMD_BTRFS is not set
# CONFIG_CMD_EXT2 is not set
CONFIG_CMD_EXT4=y
CONFIG_CMD_EXT4_WRITE=y
CONFIG_CMD_FAT=y
CONFIG_CMD_FS_GENERIC=y
# CONFIG_CMD_FS_UUID is not set
# CONFIG_CMD_JFFS2 is not set
# CONFIG_CMD_REISER is not set
# CONFIG_CMD_ZFS is not set

 

 

Do i need to add it manually ??

thanks

Ran

0 项奖励