sitronix-st7701 panel issue with kernel 5.15.71 (kirkstone)

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

sitronix-st7701 panel issue with kernel 5.15.71 (kirkstone)

771件の閲覧回数
kishan_dudhatra
Contributor III

Hi folks;
@Zhiming_Liu 

I am trying to bring up sitronix-st7701 display panel in imx8mm. This display panel is working on yocto zeus. I have ported the same driver in kirkstone. during boot time, we get the Linux logo means the display driver is working. After the boot, I am getting the below error and the display goes off.

[   14.046955] imx_sec_dsim_drv 32e10000.mipi_dsi: wait rx done time out
[   14.430905] imx_sec_dsim_drv 32e10000.mipi_dsi: wait payload tx done time out

 But after restarting Weston service display works.

Anyone can suggest where to debug?

Regards,
Kishan Dudhatra
0 件の賞賛
5 返答(返信)

747件の閲覧回数
Bio_TICFSL
NXP TechSupport
NXP TechSupport
0 件の賞賛

735件の閲覧回数
kishan_dudhatra
Contributor III

Hi @Bio_TICFSL 

Thanks for the quick reply.

I have read this thread https://community.nxp.com/t5/i-MX-Processors/how-to-add-a-new-panel-with-imx8mm-evk-I-got-some-probl...  but unable to get the solutions for the below error logs.

[   14.046955] imx_sec_dsim_drv 32e10000.mipi_dsi: wait rx done time out
[   14.430905] imx_sec_dsim_drv 32e10000.mipi_dsi: wait payload tx done time out

As previously I mentioned this display is working on Zeus kernel 4.9 but goes off on Kirkstone kernel 5.15.71 after booting and need to restart the Weston services. We also got the Linux logo on display during the boot which means the display driver is working. After restarting the Weston service display is working. Can you please provide suggestions on mentioned error logs?

Thanks in advance. 

Regards,
Kishan Dudhatra
0 件の賞賛

690件の閲覧回数
kishan_dudhatra
Contributor III

Hi @Bio_TICFSL ,

Can you please provide suggestions for the issue?

Regards,
Kishan Dudhatra
0 件の賞賛

510件の閲覧回数
Udhay_
Contributor III

@kishan_dudhatra 

did you resolve this?

 

タグ(1)
0 件の賞賛

458件の閲覧回数
kishan_dudhatra
Contributor III
@Udhay_
systemd-backlight@.service was causing issues, so I removed the service.

Regards,
Kishan Dudhatra
0 件の賞賛