"MMC: no card present" issue in u-boot and Kernel does not start

cancel
Showing results for 
Search instead for 
Did you mean: 

"MMC: no card present" issue in u-boot and Kernel does not start

78 Views
AkiyoshiOhira
Contributor I

"MMC: no card present" issue in u-boot and Kernel does not start

When I start SD boot with a custom board based on i.mx8mini, "MMC: no card present" issue in u-boot and Kernel does not start.

The environment in which it is implemented is as follows.
-----
yocto:imx-linux-kirkstone
Kernel: imx-5.15.52-2.1.0.xml
-----

We have confirmed the following:
Execute the following command in u-boot.
-----
u-boot=> mmc dev 0
MMC Device 0 not found
no mmc device at slot 0
u-boot=> mmc dev 1
MMC: no card present
u-boot=> mmc dev 2
switch to partitions #0, OK
mmc2(part 0) is current device
-----

mmc dev 1 is not recognized.
What should I check and fix?

Attached the "imx8mini_kirkston_uboot.log“ log when the problemed issue.

Best, Regars,
AKiyoshi Ohira

Labels (1)
0 Kudos
5 Replies

71 Views
joanxie
NXP TechSupport
NXP TechSupport
0 Kudos

58 Views
AkiyoshiOhira
Contributor I

I checked using the following "i.MX8MMini EVK" demo images, but Kernel does not start.

image used
LF_v5.15.52-2.1.0_images_IMX8MMEVK.zip
 →imx-image-multimedia-imx8mmevk.wic

I also attach the log(imx8mini_demo_images_uboot.log).

Best, Regars,
AKiyoshi Ohira

0 Kudos

52 Views
joanxie
NXP TechSupport
NXP TechSupport

pls let me check your uboot environment by the "pirntenv"

0 Kudos

40 Views
AkiyoshiOhira
Contributor I

I've attached the printenv log.

Best, Regars,
AKiyoshi Ohira

0 Kudos

8 Views
joanxie
NXP TechSupport
NXP TechSupport

how about setting mmcdev to 2 and mmcroot to "/dev/mmcblk2p2 rootwait rw"?
can the board boot up?

Tags (1)
0 Kudos