iMX8MQ CSI cannot pass received data to frame buffer

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

iMX8MQ CSI cannot pass received data to frame buffer

687 Views
yong_gao
Contributor I

Hello, 

We had added Onsemi sensor driver into Google Coral Dev board. The system is working and can get 1080p30 and 720p30 streaming correctly. But some times, after boot up, the system cannot streaming.

After debugging,  found the no streaming issue is related to iMX8 CSI block. When streaming properly, read “CSI Status Register” BIT0 value, most of time is zero. That mean RXFIFO is not ready --- image data have been passed to frame buffer quickly. But when no streaming issue occur, the “CSI Status Register” BIT0 most of time is one. That mean RXFIFO is full but image data did not passed to frame buffer. Looks like the DMA is not working properly. Same time checked “CSI DMA Start Address Register” FB1 and FB2, when streaming properly, their value are dynamically change. When no streaming issue occur, FB1 and FB2 value are fixed.

When no streaming issue occur, read "CSI Control Register 3" frame counter, the number is increasing. It is same as streaming work case.

 

The issue looks like iMX8 CSI block did not be initialed properly in boot up time. Any idea to debug and fix the problem?

Thanks,

Yong Gao

0 Kudos
3 Replies

681 Views
igorpadykov
NXP Employee
NXP Employee

Hi Yong

 

for RXFIFO issues one can try suggestions provided on

https://community.nxp.com/t5/i-MX-Processors/RX-fifo-overflow-on-MIPI-CSI2-i-MX8MQ/m-p/1087697?comme...

 

Best regards
igor

0 Kudos

657 Views
yong_gao
Contributor I

Hi Igor,

Checked RXFIFO overflow issue, it is related to CPU loading. But our issue occur just after linux boot up before run any applications. Also noticed the issue is very easy occur when system become hot. After system become hot, reboot linux, will much easy to trigger the problem. When system is could, I never reproduce the problem. Not sure how to fix it.

Thanks,

Yong

0 Kudos

647 Views
igorpadykov
NXP Employee
NXP Employee

Hi Yong

 

please try to reproduce issue on NXP i.MX8MQ EVK reference board

with official linux releases from source.codeaurora.org/external/imx/linux-imx repository


https://source.codeaurora.org/external/imx/linux-imx/tree/?h=imx_5.4.24_2.1.0

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

 

Best regards
igor

0 Kudos