iMX8MP + DDR4 Bringup : ATF(BL31) not found

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

iMX8MP + DDR4 Bringup : ATF(BL31) not found

跳至解决方案
1,550 次查看
khang_letruong
Senior Contributor III

Dear i.MX u-Boot Experts,

We inspired the iMX8MP-DDR4-EVK design for our custom board. The only change for the CPU/SOM board is the DDR4 capacity but the training was successful.

Our custom board does NOT have eMMC, just similar to iMX8MP-DDR4-EVK as well.

However, the booting (from micro SD card) of our custom board seems to be stuck as it could not find the ATF because of wrong magic word returned by image_get_magic(header) in arch/arm/mach-imx/spl_imx_romapi.c:

 

>>SPL: board_init_r()
spl_init
SEC0:  RNG instantiated
Normal Boot
WDT:   Not found!
Trying to boot from BOOTROM
image offset 0x8000, pagesize 0x200, ivt offset 0x0
ROMAPI: Header magic found 0xe6666262
Can't support legacy image
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

 

The returned value was 0xe6666262, while the expected value is 0xd00dfeed (FDT_MAGIC).

I have not been able to identify the issue yet. Could you help?

Best Regards,
Khang

0 项奖励
回复
1 解答
1,416 次查看
AldoG
NXP TechSupport
NXP TechSupport

Hello,

I cannot see anything wrong with the steps you have provided by the log error there seems to be some errors in the ATF, if you revert your patch to the ATF are you able to boot?

Also, there are no other difference between EVK and your board, aside from DDR4?

Best regards,
Aldo.

在原帖中查看解决方案

0 项奖励
回复
5 回复数
1,520 次查看
AldoG
NXP TechSupport
NXP TechSupport

Hello,

Could you provide the BSP version that you are trying to use?
Also, please share the steps you have followed to build your image.

Best regards,
Aldo.

0 项奖励
回复
1,507 次查看
khang_letruong
Senior Contributor III

Dear @AldoG ,

I am testing both BSP LF5.10.52-2.1.0 and LF5.10.72-2.2.0. Steps are :

1. u-Boot: Adapt the imx8mp-ddr4-evk to our custom board by updating the DDR4 timing and capacity (as it is the main difference btw the 2 boards) and generate patches (see attachment)

2. Add patches to imx-yocto-bsp/sources/meta-imx/meta-bsp/recipes-bsp/u-boot/files/ and add imx-yocto-bsp/sources/meta-imx/meta-bsp/recipes-bsp/u-boot/u-boot-imx_%.bbappend  as below:

SRC_URI += " \
file://0001-Adapt-iMX8MP-DDR4-EVK-to-VIPER-board.patch \
file://0002-ROMAPI-Show-header-magic.patch \
"

3. Bitbake the firmware :

$ DISTRO=fsl-imx-xwayland MACHINE=imx8mp-ddr4-evk source imx-setup-release.sh -b build-xwayland-viper_imx8mp/

$ bitbake imx-image-multimedia

Best Regards,

Khang

0 项奖励
回复
1,426 次查看
khang_letruong
Senior Contributor III

Hi @AldoG ,

Have you found something about my steps, please?

Best Regards,
Khang

0 项奖励
回复
1,417 次查看
AldoG
NXP TechSupport
NXP TechSupport

Hello,

I cannot see anything wrong with the steps you have provided by the log error there seems to be some errors in the ATF, if you revert your patch to the ATF are you able to boot?

Also, there are no other difference between EVK and your board, aside from DDR4?

Best regards,
Aldo.

0 项奖励
回复
1,413 次查看
khang_letruong
Senior Contributor III

Hi @AldoG ,

if you revert your patch to the ATF are you able to boot?

For the adaptation from DDR4-EVK to our custom board, I did not apply any patch to ATF, so I do NOT know what to revert.

Also, there are no other difference between EVK and your board, aside from DDR4?

There's some additional difference :

1. We use USB2 for OTG/Serial Downloader as mentioned in https://community.nxp.com/t5/i-MX-Processors/iMX8MPlus-u-Boot-Flash-issue-Serial-Downloader-mode/m-p... and we tried the patch https://community.nxp.com/t5/i-MX-Processors-Knowledge-Base/Sharing-i-MX8MP-Download-image-via-USB-O... as you suggested.

2. Compared to DDR4-EVK, we do NOT have NAND memory; compared to LPDDR4-EVK, we do NOT have eMMC.

Best Regards,
Khang

 

0 项奖励
回复