iMX8 GPU Performance

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

iMX8 GPU Performance

1,991 次查看
Hardik85
Contributor I

Hi,

I am working with iMX8mmini and trying to increase GPU performance. using below command I found that currently GPU is running @ 500 MHz. As per datasheet or device tree node GPU is running at nominal frequency of 800 MHz (Max Support 1000 MHz). I need help to increase GPU performance i.e. increase GPU frequency to 800 MHz.

Currently I am using kernel 5.4.142 and below is O/P of GPU clk

cat /sys/kernel/debug/gc/clk
gpu0 mc clock: 499995861 HZ.
gpu0 sh clock: 499995861 HZ.
gpu8 mc clock: 499998777 HZ.

Thank you,

Hardik patel

0 项奖励
5 回复数

924 次查看
ItamarE
Contributor I

Any news about this?
I am experiencing the same issues on IMX8-Nano on the latest release: 5.15.71.

Thanks.

0 项奖励

1,784 次查看
CharrB
Contributor I

Hi @Hardik85, @Bio_TICFSL 

 

Did you manage to resolve your problem. I am currently in front of the same situation. I see that GPU_PLL is set to 1GHz, however debugfs entry for gpu0 shows 500MHz. Does GPU really operate at 500MHz, or is it a debugfs query error ? Shall we expect double the GPU clock moving to BSP5.10.72 or any newer BSP and by that increasing GPU performance ?

The same results:

imx8mm:/sys/kernel/debug/gc# cat clk
gpu0 mc clock: 499978008 HZ.
gpu0 sh clock: 499978008 HZ.
gpu8 mc clock: 500011499 HZ.

Best regards,

CharrB

0 项奖励

1,971 次查看
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Hardik85,

You need to change your kernel and BSP to 5.10.72:

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

 

Regards

0 项奖励

1,937 次查看
Hardik85
Contributor I

Hi @Bio_TICFSL 

 

Thank you for your response. I gave a try to the demo image of the latest kernel(5.10.72) and still, I am getting 500 MHz only.

Can you guide me on how to increase it to 800 MHz?

 

Regards,

Hardik

0 项奖励

1,553 次查看
mharg
Contributor I

Hi @Bio_TICFSL ,

We are also seeing the IMX8 Mini running at 500MHz.

We've deployed the latest release: imx-5.15.32-2.0.0, but it still reports as 500MHz in both sysfs, and when performing a 'QueryChipFrequency' ioctl request on '/dev/galcore'

Is there some other configuration that needs to be modified to support the higher frequency operation?

@Hardik85/ @CharrB , did either of you manage to get the GPU running at 800MHz ?

Thanks,
Mik.

0 项奖励