i.MX6SX QSPI Boot on SabreSDB

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

i.MX6SX QSPI Boot on SabreSDB

ソリューションへジャンプ
923件の閲覧回数
Balaji_ng
Contributor III

Hi all,

     I am having tough time to boot from QSPI Flash on i.MX6SX Sabre SDB board. I am using the Manufacturing tool from NXP site, I am flashing the following files to the QSPI Flash:

U-BOOT File:

files/u-boot-imx6sxsabresd_qspi2.imx

Flash Configuration File:

files/qspi-nor-micron-n25q256a-config

U-BOOT offset:

seek=1

Flash Configuration Offset:

hdrseek=0

Following are the Boot Configuration Switch Settings:

SW10=>00000000

SW11=>00000000

SW12=>00011000

The board does not boot. Is there anything that I am missing? Am I using the correct files?  or Should I use different files?

Any suggestions/pointers/references are greatly appreciated.

Regards,

Balaji.V

ラベル(1)
0 件の賞賛
1 解決策
614件の閲覧回数
igorpadykov
NXP Employee
NXP Employee

Hi Balaji

for programming please use *.vbs script mfgtool2-yocto-mx6-sabresd-qspi-nor.vbs

and look at below links

https://community.freescale.com/thread/357869

iMX6SX QSPI boot 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

元の投稿で解決策を見る

2 返答(返信)
615件の閲覧回数
igorpadykov
NXP Employee
NXP Employee

Hi Balaji

for programming please use *.vbs script mfgtool2-yocto-mx6-sabresd-qspi-nor.vbs

and look at below links

https://community.freescale.com/thread/357869

iMX6SX QSPI boot 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

614件の閲覧回数
Balaji_ng
Contributor III

Thank you Igor,

I could get it working. Following are the files that I used:

u-boot binary that is flashed onto QSPI Flash (N25Q256A): u-boot-imx6sxsabresd_qspi2.imx (available as a part of mfgtool)

Also attaching the cfg.ini and the NOR Config file that worked.

Hope this information might help someone.

0 件の賞賛