gst-fsl-plugins build failed

cancel
Showing results for 
Search instead for 
Did you mean: 

gst-fsl-plugins build failed

Jump to solution
7,619 Views
richagoel
Contributor II

Hi,

I am using imx6q sabresd board.I am trying to build the gstreamer plugins.For the gstreamer to work,the package gst-fsl-plugins is required.But as i enable this package,I mam getting the following logs-

Processing: firmware-imx
=========================

Processing: imx-lib
=====================

Processing: imx-test
======================

Processing: kobs-ng
=====================

Processing: libfslcodec
=========================
Build path taken because: no prebuilt rpm,
Testing network connectivity
OK GPP:

Try libfslcodec-3.0.7.tar.gz.md5 from the GPP
http://bitshrine.org/gpp/libfslcodec-3.0.7.tar.gz.md5:
09:25:46 ERROR 404: Not Found.
Try libfslcodec-3.0.7.tar.gz from the GPP
http://bitshrine.org/gpp/libfslcodec-3.0.7.tar.gz:
09:25:51 ERROR 404: Not Found.
Can't get: libfslcodec-3.0.7.tar.gz at ./ltib line 802.


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Wed Jun  5 09:22:28 2013
Ended:   Wed Jun  5 09:25:51 2013
Elapsed: 203 seconds

These packages failed to build:
libfslcodec

Build Failed

Can anybody please help me with this issue?

Labels (1)
1 Solution
1,465 Views
jimmychan
NXP TechSupport
NXP TechSupport

please go to edit the ltib/dist/lfs-5.1/gst-plugins-good/gst-plugins-good.spec

use # to comment out the followings cairo things like this :

#export CAIRO_CFLAGS=-I/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/include/cairo

#export CAIRO_LIBS=-L/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/lib/cairo

#export LIBS=-lcairo

View solution in original post

11 Replies
1,466 Views
tejasshah
Contributor III

Hi Leo,

I was able to compile gst-fsl-plugins properly and can also use this command,

gst-launch v4l2src device=/dev/video1 ! ffmpegcolorspace ! mfw_v4lsink.

I just had to add ffmpegcolorspace to what you gave me before for web camera to start and capture the video.

Can you please tell me how can I save the captured video?

0 Kudos
1,466 Views
LeonardoSandova
Specialist I

Check the filesink gst element. In case you need to store the encoded video, you also need to add a encoder element into the pipeline.

Leo

0 Kudos
1,466 Views
jimmychan
NXP TechSupport
NXP TechSupport

Please download the Multimedia Codec package from here:

http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=IMX6_SW

1,466 Views
richagoel
Contributor II

Thnx jimmychan..It worked!

I am having problem building ltib with gst-plugins-good.

Processing: gst-plugins-good
==============================
Build path taken because: directory build, build key set, no prebuilt rpm,

rpmbuild --dbpath /home/ashish/Desktop/dev_imx6/ltib/rootfs//var/lib/rpm --target arm --define '_unpackaged_files_terminate_build 0' --define '_target_cpu arm' --define '__strip strip' --define '_topdir /home/ashish/Desktop/dev_imx6/ltib/rpm' --define '_prefix /usr' --define '_tmppath /home/ashish/Desktop/dev_imx6/ltib/tmp' --define '_rpmdir /home/ashish/Desktop/dev_imx6/ltib/rpm/RPMS'  --define '_mandir /usr/share/man' --define '_sysconfdir /etc' --define '_localstatedir /var' -bc --short-circuit  /home/ashish/Desktop/dev_imx6/ltib/dist/lfs-5.1/gst-plugins-good/gst-plugins-good.spec
Building target platforms: arm
Building for target arm
Executing(%build): /bin/sh -e /home/ashish/Desktop/dev_imx6/ltib/tmp/rpm-tmp.26615
+ umask 022
+ cd /home/ashish/Desktop/dev_imx6/ltib/rpm/BUILD
+ cd gst-plugins-good-0.10.30
+ export CAIRO_CFLAGS=-I/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/include/cairo
+ export CAIRO_LIBS=-L/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/lib/cairo
+ export LIBS=-lcairo
+ ./configure --prefix=/usr --host=arm-linux --build=i686-pc-linux-gnu --without-check --disable-speex --disable-shout2test --disable-shout2 --disable-dv1394 --disable-libpng --disable-libdv --disable-libcaca --disable-ladspa --disable-jpeg --disable-flac --disable-esd --disable-esdtest --disable-cairo --disable-aalib --disable-aalibtest --disable-x --disable-xvideo --disable-hal NM=nm
configure: WARNING: unrecognized options: --without-check, --disable-ladspa
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for arm-linux-strip... arm-linux-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking nano version... 0 (release)
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnu
checking host system type... arm-unknown-linux-gnu
checking how to print strings... printf
checking for style of include used by make... GNU
checking for arm-linux-gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/ashish/Desktop/dev_imx6/ltib/rpm/BUILD/gst-plugins-good-0.10.30':
configure: error: C compiler cannot create executables
See `config.log' for more details
error: Bad exit status from /home/ashish/Desktop/dev_imx6/ltib/tmp/rpm-tmp.26615 (%build)


RPM build errors:
    Bad exit status from /home/ashish/Desktop/dev_imx6/ltib/tmp/rpm-tmp.26615 (%build)
Build time for gst-plugins-good: 1 seconds

Failed building gst-plugins-good


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Wed Jun  5 12:57:04 2013
Ended:   Wed Jun  5 12:57:06 2013
Elapsed: 2 seconds

These packages failed to build:
gst-plugins-good

Build Failed

Exiting on error or interrupt

1,466 Views
jimmychan
NXP TechSupport
NXP TechSupport

please go to edit the ltib/dist/lfs-5.1/gst-plugins-good/gst-plugins-good.spec

use # to comment out the followings cairo things like this :

#export CAIRO_CFLAGS=-I/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/include/cairo

#export CAIRO_LIBS=-L/home/ashish/Desktop/dev_imx6/ltib/rootfs/usr/lib/cairo

#export LIBS=-lcairo

1,466 Views
richagoel
Contributor II

Thnx Jimmy!

I am able to build my ltib with gstreamer-plugins-good , gst-fsl-plugins and  gst-fsl-plugins.I am able to play the default video which is under unit_tests but i am not able to play any other video other than the default one.

gplay Cutie.mpeg

playbin2 is employed!

fsl_player_init(): Successfully initialize!

fsl_player_set_media_location(): filename=Cutie.mpeg

[Stopped  ][Vol=01][00:00:00/00:00:00][fps:0]Aiur: 3.0.7

Core: BLN_MAD-MMLAYER_MPG2PARSER_04.04.11  build on Feb 21 2013 14:11:55

  mime: video/mpeg, mpegversion=(int)[1,2]; video/mpegts, systemstream=true; video/x-cdxa

  file: /usr/lib/imx-mm/parser/lib_mpg2_parser_arm11_elinux.so.3.1

Content Info:

        URI:

              file:///home/user/Cutie.mpeg

        Idx File:

              /root/.aiur/.home.user.Cutie.mpeg.aidx

        Seekable  : Yes

        Size(byte): 4866460

Mpeg2CreateParser:parser created successfully

Movie Info:

        Seekable  : Yes

        Live      : No

        Duration  : 0:01:03.900000000

        ReadMode  : File

        programs    : 1

        Track     : 2

Track 00 [video_000000] Enabled

        ppid: 0, ppid 0

        Duration: 0:01:03.880000000

        Language: und

        Mime:

              video/mpeg, systemstream=(boolean)false, parsed=(boolean)true, mpegversion=(int)

              2, width=(int)320, height=(int)240, framerate=(fraction)25/1, codec_data=(buffer

              )000001b31400f0130138a0a51011111212121313131314141414141515151515151616161616161

              6171717171717171718181818181818191a191a1a191b1b1b1a1b1c1c1c1c1e1e1e1f1f21000001b

              800080040

Track 01 [audio_000001] Enabled

        ppid: 0, ppid 1

        Duration: 0:01:03.900000000

        Language: und

        Mime:

              audio/mpeg, mpegversion=(int)1, framed=(boolean)true, channels=(int)1, rate=(int

              )32000, bitrate=(int)96

Aiur: 3.0.7

Core: BLN_MAD-MMLAYER_MPG2PARSER_04.04.11  build on Feb 21 2013 14:11:55

  mime: video/mpeg, mpegversion=(int)[1,2]; video/mpegts, systemstream=true; video/x-cdxa

  file: /usr/lib/imx-mm/parser/lib_mpg2_parser_arm11_elinux.so.3.1

Content Info:

        URI:

              file:///home/user/Cutie.mpeg

        Idx File:

              /root/.aiur/.home.user.Cutie.mpeg.aidx

        Seekable  : No

        Size(byte): -1

FOUND GST_MESSAGE_TAG!

          codec: MPEG2

  language code: und

        bitrate: 500000

FOUND GST_MESSAGE_TAG!

container format: MPEG

FOUND GST_MESSAGE_TAG!

          codec: MP3

  language code: und

        bitrate: 96

state change failed from 2 to 4

try to play failed

Debug: aiurdemux.c(4262): aiurdemux_push_task (): /GstPlayBin2:playbin0/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/GstAiurDemux:aiurdemux1:

streaming stopped, reason error

Error: GStreamer encountered a general stream error.

[Stopped  ][Vol=01][00:00:00/00:00:00][fps:0]

FSL_PLAYER_01.00_LINUX build on Jun  5 2013 12:55:46

        [h]display the operation Help

        [p]Play

        [s]Stop

        [e]Seek

        [a]Pause when playing, play when paused

        [v]Volume

fsl_player_stop()

        [m]Switch to mute or not

        [>]Play next file

        [<]Play previous file

        [r]Switch to repeated mode or not

        [f]Set full screen or not

        [z]resize the width and height

        [t]Rotate

        [c]Setting play rate

        [i]Display the metadata

        [x]eXit

FSL_PLAYER_UI_MSG_INTERNAL_ERROR: internal error message received.

fsl_player_stop()

player_exit(): No more multimedia files, exit.

[Stopped  ][Vol=01][00:00:00/00:00:00][fps:0]g_main_loop_thread_fun() quit!

fsl_player_deinit

Can u please help with playing videos??

0 Kudos
1,465 Views
东兰
Contributor I

hi,the FSL_PLAYER_UI_MSG_INTERNAL_ERROR: internal error message received. ,are you ok ? i have the same qustion

0 Kudos
1,466 Views
jimmychan
NXP TechSupport
NXP TechSupport

Please check the Release Note of the Multimedia codes. Due to license limitation, not all the video formats supported. If you have any new question/problem, it is better to create another new post. Thanks. :smileyhappy:

1,466 Views
tejasshah
Contributor III

Hello jimmychan,

I am using iMX6 Sololite board and I have been trying to build gstreamer plugin. I am getting similar error as given above when I am trying to enable gst-fsl-plugin. I went to gst-plugins-good spec file but there was no cairo in my gst-plugins-good spec file. In my spec file it has following things:

%Build

./configure --prefix=%{_prefix} --host=$CFGHOST \
        --build=%{_build} --without-check \
        --disable-speex \
        --disable-shout2test --disable-shout2 \
        --disable-dv1394 --disable-libpng \
        --disable-libdv --disable-libcaca \
        --disable-ladspa --disable-jpeg \
        --disable-flac \
        --disable-esd --disable-esdtest \
        --disable-cairo --disable-aalib \
        --disable-aalibtest --disable-x \
        --disable-xvideo --disable-hal NM=nm

Here is my error. Please I need your help. It is very urgent.

Processing: libfslcodec

=========================

Processing: libfslparser

==========================

Processing: gst-fsl-plugins

=============================

Build path taken because: directory build, no prebuilt rpm,

scbuild/scdeploy already unpacked package

Processing: gst-fsl-plugins

=============================

Build path taken because: directory build, build key set, no prebuilt rpm,

rpmbuild --dbpath /home/pshah9/Documents/imx6install/ltib/rootfs//var/lib/rpm --target arm --define '_unpackaged_files_terminate_build 0' --define '_target_cpu arm' --define '__strip strip' --define '_topdir /home/pshah9/Documents/imx6install/ltib/rpm' --define '_prefix /usr' --define '_tmppath /home/pshah9/Documents/imx6install/ltib/tmp' --define '_rpmdir /home/pshah9/Documents/imx6install/ltib/rpm/RPMS'  --define '_mandir /usr/share/man' --define '_sysconfdir /etc' --define '_localstatedir /var' -bc --short-circuit  /home/pshah9/Documents/imx6install/ltib/dist/lfs-5.1/fsl-mm/gst-fsl-plugins.spec

Building target platforms: arm

Building for target arm

Executing(%build): /bin/sh -e /home/pshah9/Documents/imx6install/ltib/tmp/rpm-tmp.82439

+ umask 022

+ cd /home/pshah9/Documents/imx6install/ltib/rpm/BUILD

+ cd gst-fsl-plugins-3.0.3

+ which pkg-config

+ export PKG_CONFIG=/opt/freescale/ltib/usr/bin/pkg-config --static

+ echo imx6s

+ sed s,imx\([0-9]*\).*,MX\1,g

+ PLATFORMSHORTNAME=MX6

+ [ xMX6 = xMX27 ]

+ export FBHEADER_PATH=/home/pshah9/Documents/imx6install/ltib/rootfs/usr/src/linux/include/

+ echo imx6s

+ sed s,imx\([0-9]*\).*,MX\1,g

+ ./autogen.sh PLATFORM=MX6

+ aclocal

+ libtoolize --force

libtoolize: putting auxiliary files in `.'.

libtoolize: linking file `./ltmain.sh'

libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.

libtoolize: linking file `m4/libtool.m4'

libtoolize: linking file `m4/ltoptions.m4'

libtoolize: linking file `m4/ltsugar.m4'

libtoolize: linking file `m4/ltversion.m4'

libtoolize: linking file `m4/lt~obsolete.m4'

+ automake -a

Makefile.am:947: `%'-style pattern rules are a GNU make extension

+ autoconf

+ conf_flags=--enable-maintainer-mode

+ test x = x

+ echo Running ./configure --enable-maintainer-mode PLATFORM=MX6 ...

Running ./configure --enable-maintainer-mode PLATFORM=MX6 ...

+ ./configure --enable-maintainer-mode PLATFORM=MX6

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... no

checking for mawk... mawk

checking whether make sets $(MAKE)... yes

checking whether to enable maintainer-specific portions of Makefiles... yes

checking for gcc... gcc

checking whether the C compiler works... yes

checking for C compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking for style of include used by make... GNU

checking dependency style of gcc... gcc3

checking whether gcc and cc understand -c and -o together... yes

checking build system type... x86_64-unknown-linux-gnu

checking host system type... x86_64-unknown-linux-gnu

checking how to print strings... printf

checking for a sed that does not truncate output... /bin/sed

checking for grep that handles long lines and -e... /bin/grep

checking for egrep... /bin/grep -E

checking for fgrep... /bin/grep -F

checking for ld used by gcc... ld

checking if the linker (ld) is GNU ld... yes

checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B

checking the name lister (/usr/bin/nm -B) interface... BSD nm

checking whether ln -s works... yes

checking the maximum length of command line arguments... 1572864

checking whether the shell understands some XSI constructs... yes

checking whether the shell understands "+="... yes

checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-linux-gnu format... func_convert_file_noop

checking how to convert x86_64-unknown-linux-gnu file names to toolchain format... func_convert_file_noop

checking for ld option to reload object files... -r

checking for objdump... objdump

checking how to recognize dependent libraries... pass_all

checking for dlltool... no

checking how to associate runtime and link libraries... printf %s\n

checking for archiver @FILE support... @

checking for strip... strip

checking for ranlib... ranlib

checking command to parse /usr/bin/nm -B output from gcc object... ok

checking for sysroot... no

checking for mt... mt

checking if mt is a manifest tool... no

checking how to run the C preprocessor... gcc -E

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking for dlfcn.h... yes

checking for objdir... .libs

checking if gcc supports -fno-rtti -fno-exceptions... no

checking for gcc option to produce PIC... -fPIC -DPIC

checking if gcc PIC flag -fPIC -DPIC works... yes

checking if gcc static flag -static works... yes

checking if gcc supports -c -o file.o... yes

checking if gcc supports -c -o file.o... (cached) yes

checking whether the gcc linker (ld -m elf_x86_64) supports shared libraries... yes

checking whether -lc should be explicitly linked in... no

checking dynamic linker characteristics... GNU/Linux ld.so

checking how to hardcode library paths into programs... immediate

checking whether stripping libraries is possible... yes

checking if libtool supports shared libraries... yes

checking whether to build shared libraries... yes

checking whether to build static libraries... yes

checking for pkg-config... yes

configure: build for MX6

checking pkg-config is at least version 0.9.0... yes

checking for GST... no

configure: error: you need gstreamer development packages installed !

+ exit 1

error: Bad exit status from /home/pshah9/Documents/imx6install/ltib/tmp/rpm-tmp.82439 (%build)

RPM build errors:

    Bad exit status from /home/pshah9/Documents/imx6install/ltib/tmp/rpm-tmp.82439 (%build)

Build time for gst-fsl-plugins: 14 seconds

Failed building gst-fsl-plugins

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Tue Jun 11 15:24:10 2013

Ended:   Tue Jun 11 15:41:34 2013

Elapsed: 1044 seconds

These packages failed to build:

gst-fsl-plugins

Build Failed

Exiting on error or interrupt


0 Kudos
1,466 Views
LeonardoSandova
Specialist I

I believe you are building this packages independently (with ltib -p , this way if pkg dependencies are not present on target, then you get a configuration error, the error you are seeing). It is best to select the good package from the ltib menu, then save configuartion and run ltib again (no arguments). This way you got all package dependencies included.

Leo

0 Kudos
1,466 Views
tejasshah
Contributor III

After selecting gst-fsl-plugin, I am just running ./ltib (without any arguments).

I have installed all of these gstreamer development packages.

sudo apt-get install libdbus-1-dev libdbus-glib-1-dev libgstreamer0.10-dev libreadline-dev libgstreamer-plugins-base0.10-dev

0 Kudos