bitbake build failed error code '1'

取消
显示结果 
搜索替代 
您的意思是: 
已解决

bitbake build failed error code '1'

跳至解决方案
9,822 次查看
redwill
Contributor II

1. trying to build by "bitbake fsl-image-validation-imx"
but meet error:
ERROR: Task (/home/.../imx-yocto-bsp/sources/poky/meta/recipes-graphics/vulkan/vulkan_1.0.65.2.bb:do_compile) failed with exit code '1'

2. trying to build by "bitbake core-image-minimal"
but meet error:
ERROR: Task (/home/.../imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-graphics/opencv/opencv_4.0.1.imx.bb:do_compile) failed with exit code '1'

#Note: I'd try these building and success weeks ago..., how can i solve these error

0 项奖励
1 解答
9,806 次查看
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello

 

This errors is happened because you need to setting up your host, for ubuntu 18:

https://www.yoctoproject.org/docs/latest/brief-yoctoprojectqs/brief-yoctoprojectqs.html

 

Regards

 

 

在原帖中查看解决方案

0 项奖励
4 回复数
9,818 次查看
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello redwill,

 

You have to erase everything from the carpet build, and rebuild again the yocto, also make sure that you are posting well the distro and machine of the build.

 

Regards

 

0 项奖励
9,814 次查看
redwill
Contributor II

Build Configuration:
BB_VERSION = "1.38.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "ubuntu-18.04"
TARGET_SYS = "aarch64-poky-linux"
MACHINE = "imx8mqevk"
DISTRO = "fsl-imx-wayland"
DISTRO_VERSION = "4.14-sumo"
TUNE_FEATURES = "aarch64"
TARGET_FPU = ""


| aarch64-poky-linux-libtool: link: aarch64-poky-linux-g++ --sysroot=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0=/usr/src/debug/v4l-utils/1.12.3-r0 -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot= -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot-native= -fvisibility-inlines-hidden -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -pthread -o cec-compliance cec-compliance.o cec-test.o cec-test-adapter.o cec-test-audio.o cec-test-power.o -lrt -pthread
| make[3]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-compliance'
| Making all in cec-follower
| make[3]: Entering directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-follower'
| ../../../v4l-utils-1.12.3/utils/cec-ctl/msg2ctl.pl 2 ../../../v4l-utils-1.12.3/include/linux/cec.h ../../../v4l-utils-1.12.3/include/linux/cec-funcs.h >cec-table.h
| aarch64-poky-linux-g++ --sysroot=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot -DHAVE_CONFIG_H -I. -I../../../v4l-utils-1.12.3/utils/cec-follower -I../.. -I../../../v4l-utils-1.12.3/lib/include -Wall -Wpointer-arith -D_GNU_SOURCE -I../../../v4l-utils-1.12.3/include -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0=/usr/src/debug/v4l-utils/1.12.3-r0 -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot= -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot-native= -fvisibility-inlines-hidden -c -o cec-follower.o cec-follower.cpp
| aarch64-poky-linux-g++: error: cec-follower.cpp: No such file or directory
| aarch64-poky-linux-g++: fatal error: no input files
| compilation terminated.
| Makefile:556: recipe for target 'cec-follower.o' failed
| make[3]: *** [cec-follower.o] Error 1
| make[3]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-follower'
| Makefile:468: recipe for target 'all-recursive' failed
| make[2]: *** [all-recursive] Error 1
| make[2]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils'
| ERROR: oe_runmake failed
| Makefile:574: recipe for target 'all-recursive' failed
| make[1]: *** [all-recursive] Error 1
| make[1]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build'
| Makefile:501: recipe for target 'all' failed
| make: *** [all] Error 2
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/temp/log.do_compile.91419)
ERROR: Task (/home/will/work/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.12.3.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 2268 tasks of which 2267 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/home/will/work/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.12.3.bb:do_compile

0 项奖励
9,807 次查看
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello

 

This errors is happened because you need to setting up your host, for ubuntu 18:

https://www.yoctoproject.org/docs/latest/brief-yoctoprojectqs/brief-yoctoprojectqs.html

 

Regards

 

 

0 项奖励
9,794 次查看
redwill
Contributor II

Thanks for the help!
The error solved by remove all files and rebuild the image
i guess the root cause are the wrong repo files or utility files under folder "downloads"

0 项奖励