Yocto project build error | imx6sabaresd

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Yocto project build error | imx6sabaresd

ソリューションへジャンプ
1,527件の閲覧回数
soorajs
Contributor III

I have attached the ERROR Log .
Here is a pastebin link of the log , for someone like me who hates downloading attachments.
Build machine os : Arch Linux (Manjaro varient)
Build steps

$ repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-4.1-krogoth -m
imx-4.1.15-2.0.0.xml
$ repo sync
$ DISTRO=fsl-imx-x11 MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-x11
$ bitbake core-image-minimal

GCC Version : gcc (GCC) 7.2.0

ラベル(1)
1 解決策
996件の閲覧回数
soorajs
Contributor III

Here is the patchset which fixes all the fallthrough errors for gcc7 [morty] elfutils: fix building elfutils-native with GCC7 - Patchwork 

元の投稿で解決策を見る

4 返答(返信)
997件の閲覧回数
soorajs
Contributor III

Here is the patchset which fixes all the fallthrough errors for gcc7 [morty] elfutils: fix building elfutils-native with GCC7 - Patchwork 

996件の閲覧回数
Yuri
NXP Employee
NXP Employee

Hello,

  please check Host Setup environment, described  in "i.MX_Yocto_Project_User's_Guide.pdf".

Also, please try to build core-image-sato or fsl-image-gui projects.

Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

996件の閲覧回数
soorajs
Contributor III

Hello Yuri,
iam following  i.MX_Yocto_Project_User's_Guide.pdf from "fsl-yocto-L4.1.15_2.1.0-ga"
In Host Setup it recommends Ubuntu 14.04 , dont think using arch makes a diffrence .
also have same error on building core-image-sato or fsl-image-gui .
I belive this is an issue beacuse of using latest gcc 7.2.0 , is there a patch available somewere for libdwfl for building using gcc 7.2.0.

0 件の賞賛
996件の閲覧回数
soorajs
Contributor III

I downgraded gcc-multilib version 6.4 got past the previous error
New errors   https://hastebin.com/raw/nipexenoda .

0 件の賞賛