Why are ping times so bad on imx8 mini evk?

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Why are ping times so bad on imx8 mini evk?

974件の閲覧回数
hutchman
Contributor II

Hello,

We have a bunch of imx8mm Mini Evk boards.  One of our researchers noticed the ping times were averaging around 2.5ms and thinks that's way too high.  He has pinged the evk from a pc and also from one evk to another via a Ethernet switch and directly connected with same results.

So just wanted to get thoughts on what might be causing that.

I tried playing with setting net.ipv4.tcp_low_latency=1 and it didn't appear to make much of a difference.

When I run wireshark I see lots of ARP traffic going on and I suspect it's because of Avahi and other stuff installed.

Regards,

Brian

ラベル(2)
タグ(1)
0 件の賞賛
2 返答(返信)

487件の閲覧回数
NG_R3
Contributor I

Hi there,

I'm facing a similar issue with imx8M Plus, kernel 5.15.60.

I know it's been 2 years, maybe it was enough time to sort this issue out? 

If so, can you please share some details about the root cause of the problem and a possible solution?

Thanks a lot,

Nir.

0 件の賞賛

899件の閲覧回数
gusarambula
NXP TechSupport
NXP TechSupport

Hello Brian,

It would make sense that Avahi could make the ping a bit slower due to the ARP request, although shouldn’t affect that much. Have you tested the ethernet with a smaller image that does not contains it? If you want to go to the bate minimum you could test it with the core-image-minimal. Alternatively, you may try to remove it from the image build to see how it affects the ping time.

Regards,

0 件の賞賛