Wandboard DL Android 5.0 demo image is not working

取消
显示结果 
搜索替代 
您的意思是: 

Wandboard DL Android 5.0 demo image is not working

871 次查看
lyfsci
Contributor III

Hi Experts,

The Wandboard DL demo image stalls during startup. The display port used is HDMI. The android "Logo" is printed in the display but then the surface flinger stops due to bad display issue.


E/BufferQueue( 1855): [FramebufferSurface] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

With that the display freezes. The command line argument is default and am using board revision C1.

标签 (2)
3 回复数

599 次查看
art
NXP TechSupport
NXP TechSupport

Most likely, your DL board is programmed with wrong demo image for Q board. The reason for this conclusion is that the i.MX6Q and i.MX6DL processors have different graphics subsystems, that's why the DL board should hang when the wrong image starts running and the graphics is engaged. So, please check.


Have a great day,
Artur

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

599 次查看
lyfsci
Contributor III

Hi Artur,

Thanks for the reply.

I am using the standard procedure mentioned in the link Wandboard Discussion Forums • View topic - Android build steps.

But still I am facing the same issue. Here I am attaching extra logs as well.

I/FslHwcomposer(  154): hwc_device_open,426

I/SurfaceFlinger(  154): Using composer version 1.3

W/SurfaceFlinger(  154): no suitable EGLConfig found, trying a simpler query

I/SurfaceFlinger(  154): EGL information:

I/SurfaceFlinger(  154): vendor    : Android

I/SurfaceFlinger(  154): version   : 1.4 Android META-EGL

I/SurfaceFlinger(  154): extensions: EGL_KHR_get_all_proc_addresses EGL_ANDROID_presentation_time EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixm

I/SurfaceFlinger(  154): Client API: OpenGL_ES

I/SurfaceFlinger(  154): EGLSurface: 8-8-8-8, config=0x15

I/SurfaceFlinger(  154): OpenGL ES informations:

I/SurfaceFlinger(  154): vendor    : Vivante Corporation

I/SurfaceFlinger(  154): renderer  : Vivante GC880

I/SurfaceFlinger(  154): version   : OpenGL ES 3.0 V5.0.11.p4.25762

I/SurfaceFlinger(  154): extensions: GL_EXT_debug_marker GL_OES_vertex_type_10_10_10_2 GL_OES_vertex_half_float GL_OES_element_index_uint GL_OES_mapb

I/SurfaceFlinger(  154): GL_MAX_TEXTURE_SIZE = 8192

I/SurfaceFlinger(  154): GL_MAX_VIEWPORT_DIMS = 8064

E/cutils-trace(  154): Error opening trace file: Permission denied (13)

E/libEGL  (  154): eglSetSwapRectangleANDROID:1595 error 3008 (EGL_BAD_DISPLAY)

E/SurfaceFlinger(  154): HWComposer: framebufferTarget is null

E/SurfaceFlinger(  154): HWComposer: framebufferTarget is null

E/SurfaceFlinger(  154): HWComposer: framebufferTarget is null

E/SurfaceFlinger(  154): HWComposer: framebufferTarget is null

D/SurfaceFlinger(  154): Set power mode=2, type=0 flinger=0x76962000

E/        (  154): g2d_make_current: fail to set current hardware type to 1

I/FslHwcomposer(  154): prepare: targetHandle is null

D/SurfaceFlinger(  154): shader cache generated - 24 shaders in 663.922668 ms

D/libEGL  (  181): loaded /system/lib/egl/libEGL_VIVANTE.so

D/libEGL  (  181): loaded /system/lib/egl/libGLESv1_CM_VIVANTE.so

D/libEGL  (  181): loaded /system/lib/egl/libGLESv2_VIVANTE.so

E/cutils-trace(  181): Error opening trace file: Permission denied (13)

E/BufferQueueProducer(  154): [BootAnimation] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

Regards,

lyf

0 项奖励

599 次查看
art
NXP TechSupport
NXP TechSupport

Actually, Wandboard and its BSP is not the product of NXP. So, try to search/ask on the Wandboard Forums.

0 项奖励