SFTP-Server not found

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

SFTP-Server not found

跳至解决方案
6,086 次查看
inigovicentewal
Contributor III

I have tried several days to build the SFTP server on my IMX8M to debug it with eclipse but I can't get it to work.
When I search for sftp I have the following message: sftp: command not found
Any idea how to activate it on my board or why it doesn't work?

In WindSCP I have this message: I cannot initialize the SFTP protocol. Are you sure the server is running SFTP?

I have my local.conf configured correctly with: 

 

EXTRA_IMAGE_FEATURES ?= "debug-tweaks tools-debug eclipse-debug ssh-server-openssh"
CORE_IMAGE_EXTRA_INSTALL += "openssh-sftp openssh-sftp-server"

Thanks

标签 (1)
标记 (2)
0 项奖励
1 解答
5,946 次查看
karangajjar
Senior Contributor II

Hi Iñigo Vicente,

We verified in Yocto warrior Linux version 4.19.35. We added the below line in conf/local.conf.

m IMAGE_INSTALL_append += " openssh-sftp-server"

The "core-image-minimal-XXXX.wic.bz2" image generated has / usr / libexec / sftp-server .

Can you please add above mentioned line in your conf/local.conf at the end and confirm?

Regards,

Karan Gajjar

在原帖中查看解决方案

0 项奖励
3 回复数
5,946 次查看
karangajjar
Senior Contributor II

Hi Iñigo Vicente,

Can you let us know which Yocto/Linux version you are using?

We added the below line in conf/local.conf in yocto sumo 4.14.98:

IMAGE_INSTALL_append += " openssh-sftp-server"

And we are able to get /usr/libexec/sftp-server in the file-system.

Regards,

Karan Gajjar

0 项奖励
5,946 次查看
inigovicentewal
Contributor III

Hi,

The yocto version is 4.19.35 and Linux 18.04.3 LTS. My board is IMX8M MINI.

I create my image like this:

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b master
$ repo sync

$ MACHINE=imx8mmevk DISTRO=fslc-xwayland source setup-environment build

$ bitbake core-image-minimal

My local.conf looks like this:

MACHINE ??= 'imx8mmevk'
DISTRO ?= 'fslc-xwayland'
PACKAGE_CLASSES ?= 'package_rpm'
EXTRA_IMAGE_FEATURES ?= "debug-tweaks ssh-server-openssh tools-sdk tools-debug dbg-pkgs dev-pkgs eclipse-debug"
CORE_IMAGE_EXTRA_INSTALL += "openssh-sftp openssh-sftp-server"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"
BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
CONF_VERSION = "1"

DL_DIR ?= "${BSPDIR}/downloads/"
ACCEPT_FSL_EULA = "1"

I don't have / usr / libexec / sftp-server on my file-system. Why?

Thanks

0 项奖励
5,947 次查看
karangajjar
Senior Contributor II

Hi Iñigo Vicente,

We verified in Yocto warrior Linux version 4.19.35. We added the below line in conf/local.conf.

m IMAGE_INSTALL_append += " openssh-sftp-server"

The "core-image-minimal-XXXX.wic.bz2" image generated has / usr / libexec / sftp-server .

Can you please add above mentioned line in your conf/local.conf at the end and confirm?

Regards,

Karan Gajjar

0 项奖励