SABRE Platform for Smart Devices (MCIMX6DL-SDP): Linux image on SD card doesn't boot

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SABRE Platform for Smart Devices (MCIMX6DL-SDP): Linux image on SD card doesn't boot

Jump to solution
1,400 Views
markusbraitner
Contributor IV

Hi,

I’m trying to get a Linux image onto SABRE platform MCIMX6DL-SDP. Running Android from the supplied SD card works fine, but I don’t manage to get Linux running. What I did is the following:

  1. Set SW6 to “00001100” (USB OTG mode)
  2. Place empty SD card into J507 (SD3)
  3. Connect PC via Micro-USB cable to J505 for downloading and to J503 for terminal output
  4. Use the MfgTool (Mfgtools-Rel-4.1.0_130816_MX6DL_UPDATER) with the setting (cfg.ini)

[profiles]

chip = MX6DL Linux Update

[platform]

board = SabreSD

[LIST]

name = i.MX6DL-SABRESD-SD

     5. Exit MfgTool after „DONE“ is displayed via „Stop“ and „Exit“

     6. Swith SW6 to “01000010”

     7. Restart the board

Output:

U-Boot 2009.08 (Aug 16 2013 - 12:25:07)

CPU: Freescale i.MX6 family TO1.1 at 792 MHz

Thermal sensor with ratio = 186

Temperature:   43 C, calibration data 0x5975245f

mx6q pll1: 792MHz

mx6q pll2: 528MHz

mx6q pll3: 480MHz

mx6q pll8: 50MHz

ipg clock     : 66000000Hz

ipg per clock : 66000000Hz

uart clock    : 80000000Hz

cspi clock    : 60000000Hz

ahb clock     : 132000000Hz

axi clock   : 198000000Hz

emi_slow clock: 99000000Hz

ddr clock     : 396000000Hz

usdhc1 clock  : 198000000Hz

usdhc2 clock  : 198000000Hz

usdhc3 clock  : 198000000Hz

usdhc4 clock  : 198000000Hz

nfc clock     : 24000000Hz

Board: i.MX6DL/Solo-SABRESD: unknown-board Board: 0x61011 [POR ]

Boot Device: SD

I2C:   ready

DRAM:   1 GB

MMC:   FSL_USDHC: 0,FSL_USDHC: 1,FSL_USDHC: 2,FSL_USDHC: 3

*** Warning - bad CRC or MMC, using default environment

In:    serial

Out:   serial

Err:   serial

Found PFUZE100! deviceid=10,revid=11

Net:   got MAC address from IIM: 00:04:9f:02:e4:28

FEC0 [PRIME]

Hit any key to stop autoboot:  0

FEC: Link is down 7949

Using FEC0 device

TFTP from server 192.168.1.101; our IP address is 192.168.1.103

Filename 'uImage'.

Load address: 0x10800000

Loading: FEC: Link is down 7949

FEC: Link is down 7949

FEC: Link is down 7949

FEC: Link is down 7949

It seems as if U-Boot is looking for the OS via Network, can I change this somehow?

Also, I can’t stop autobooting by hitting any key (power, volume up/down)…

I used the manuals “i.MX_6DualQuad_SABRE-SD_Linux_Users_Guide.pdf” or “i.MX Development Quick Start-FAE-V3.pdf” – did I use the wrong manuals or do something else wrong?

Kind regards,

Markus

Labels (3)
0 Kudos
Reply
1 Solution
838 Views
markusbraitner
Contributor IV

I've finally found out the solution myself:

The U-Boot environment variable was incorrectly set. Setting it to

bootargs=console=ttymxc0,115200 init=/init video=mxcfb0:dev=ldb,bpp=32 video=mxcfb1:off video=mxcfb2:off fbmem=10M fb0base=0x27b00000 vmalloc=400M androidboot.console=ttymxc0 androidboot.hardware=freescale

loadaddr=0x10800000

bootargs_base=setenv bootargs console=ttymxc0,115200

bootargs_mmc=setenv bootargs ${bootargs} root=/dev/mmcblk1p1 rootwait rw video=mxcfb1:dev=ldb,LDB-XGA,if=RGB666 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24

bootcmd_mmc=run bootargs_base bootargs_mmc;mmc dev 2;mmc read ${loadaddr} 0x800 0x2000;bootm

bootcmd=run bootcmd_mmc

made Linux boot with no problems.

Maybe someone could update the MfgTool or the manuals accordingly?

Kind regards,

Markus

View solution in original post

0 Kudos
Reply
3 Replies
839 Views
markusbraitner
Contributor IV

I've finally found out the solution myself:

The U-Boot environment variable was incorrectly set. Setting it to

bootargs=console=ttymxc0,115200 init=/init video=mxcfb0:dev=ldb,bpp=32 video=mxcfb1:off video=mxcfb2:off fbmem=10M fb0base=0x27b00000 vmalloc=400M androidboot.console=ttymxc0 androidboot.hardware=freescale

loadaddr=0x10800000

bootargs_base=setenv bootargs console=ttymxc0,115200

bootargs_mmc=setenv bootargs ${bootargs} root=/dev/mmcblk1p1 rootwait rw video=mxcfb1:dev=ldb,LDB-XGA,if=RGB666 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24

bootcmd_mmc=run bootargs_base bootargs_mmc;mmc dev 2;mmc read ${loadaddr} 0x800 0x2000;bootm

bootcmd=run bootcmd_mmc

made Linux boot with no problems.

Maybe someone could update the MfgTool or the manuals accordingly?

Kind regards,

Markus

0 Kudos
Reply
838 Views
markusbraitner
Contributor IV

Another thing comes to my mind: I use a 16GB SDHC card. Does this make any parameter changes necessary?

Kind regards,

Markus

0 Kudos
Reply
838 Views
markusbraitner
Contributor IV

For more details - here are the logs from downloading the image to SD card (terminal output and MfgTool log) and from booting the sabre platform (including also printenv output):

0 Kudos
Reply