RTP Streaming using gstreamer fails - gstrtpbin element missing

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

RTP Streaming using gstreamer fails - gstrtpbin element missing

Jump to solution
3,256 Views
ottoblom
Contributor III

Hi There,

I followed the GStreamer RTP Streaming instructions, but my system doesn't have the gstrtpbin element that is being used. However, I do have udpsrc and various other elements from the plugins-good package. When I rebuild the plugin registry I see a few errors that could be a hint to someone, but unfortunately not to me. Does anyone know what could be the problem ? I'm using the 4.1.0 BSP.

MAX resolution 800x480

(gst-plugin-scanner:3559): GLib-GObject-WARNING **: cannot register existing type `GstRtpSsrcDemux'

(gst-plugin-scanner:3559): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_pad_template_new: assertion `caps != NULL' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_element_class_add_pad_template: assertion `GST_IS_PAD_TEMPLATE (templ)' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_pad_template_new: assertion `caps != NULL' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_element_class_add_pad_template: assertion `GST_IS_PAD_TEMPLATE (templ)' failed

(gst-plugin-scanner:3559): GLib-GObject-WARNING **: cannot register existing type `GstRTPMux'

(gst-plugin-scanner:3559): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gst-plugin-scanner:3559): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

Thanks,

/Otto

0 Kudos
1 Solution
1,242 Views
ottoblom
Contributor III

I disabled all other plugins (bad, ugly, farsight) and now the gstrtpbin showed up properly. So there has to be some form of conflict

View solution in original post

0 Kudos
4 Replies
1,242 Views
ottoblom
Contributor III

Btw, just to clarify - I'm running this on the imx6 board. Also, here is the ./configure output during build. It looks good assuming GstRtpBin is part of the rtpmanager.

configure: *** Plug-ins without external dependencies that will be built:

    alpha

    apetag

    audiofx

    audioparsers

    auparse

    autodetect

    avi

    cutter

    debugutils

    deinterlace

    effectv

    equalizer

    flv

    flx

    goom

    goom2k1

    icydemux

    id3demux

    imagefreeze

    interleave

    isomp4

    law

    level

    matroska

    multifile

    multipart

    replaygain

    rtp

    rtpmanager

    rtsp

    shapewipe

    smpte

    spectrum

    udp

    videobox

    videocrop

    videofilter

    videomixer

    wavenc

    wavparse

    y4m

configure: *** Plug-ins without external dependencies that will NOT be built:

    monoscope

configure: *** Plug-ins with dependencies that will be built:

    annodex

    cairooverlay

    oss4

    ossaudio

    v4l2src

configure: *** Plug-ins with dependencies that will NOT be built:

    1394

    aasink

    cacasink

    cairo

    directsoundsink

    dv

    esdsink

    flac

    gconfelements

    gdkpixbuf

    halelements

    jack

    jpeg

    osxaudio

    osxvideosink

    png

    pulseaudio

    shout2

    souphttpsrc

    speex

    sunaudio

    taglib

    wavpack

    ximagesrc

0 Kudos
1,243 Views
ottoblom
Contributor III

I disabled all other plugins (bad, ugly, farsight) and now the gstrtpbin showed up properly. So there has to be some form of conflict

0 Kudos
1,242 Views
LeonardoSandova
Specialist I

Otto, when the conflict occurred, how did you add the elements? Did you use Yocto or LTIB to do the latter?

Leo

0 Kudos
1,242 Views
ottoblom
Contributor III

Leo, we are using LTIB. I'm suspecting the farsight plugins, since they also provide RTP functionality, but have not verified it yet.

0 Kudos