NO /dev/tee* device in technexion pico-pi-imx7 board in yocto project

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NO /dev/tee* device in technexion pico-pi-imx7 board in yocto project

642 Views
gonewithwind-peter
Senior Contributor I

NO /dev/tee* device in technexion pico-pi-imx7 board in yocto project

I have opened an issue here: https://github.com/TechNexion/edm-yocto-bsp/issues/22
but nobody to answer me, so I open here again:
In yocto local.conf I added: DISTRO_FEATURES_append=" optee"
IMAGE_INSTALL_append = " optee-client-imx optee-os-imx-tn optee-test-imx"
and
config CONFIG_OPTEE in kernel config,but I still can not find the device /dev/tee ?

any suggestion? how can I do? individually to build kernel,boot and rootfs?
Thanks


error:

ls /dev/tee*
ls: cannot access '/dev/tee*': No such file or directory
fortress:/usr/include# xtest
Run test suite with level=0

TEE test application started with device [(null)]
Failed to open TEE context: 0xffff0008
fortress:/usr/include# tee-supplicant
ERR [576] TEES:main:663: failed to find an OP-TEE supplicant device
fortress:/usr/include#

Labels (3)
Tags (1)
2 Replies

494 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Peter Zhang,

The PICO-PI-IMX7 board is manufactured and supported by TechNexion so you have followed the correct path. I’m glad to see that there were some replies already.

Regards,

494 Views
gonewithwind-peter
Senior Contributor I

thank you.

the engineer in TechNexion told me they did not port the source code for PICO-PI-IMX7 . and give me a reference :GitHub - ARMmbed/meta-mbl: Mbed Linux OS (mbl) main repository & OpenEmbedded layers .

that means I need port it by myself. is it complex? or how can I port into TechNexion source code from the refer or  from the imx7dsabresd ? please give me  some idea. it look like the optee source code can not directly support PICO-PI-IMX7.

0 Kudos