Modification of the UBOOT for UART in SABRE AI Quad CPU Card.

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Modification of the UBOOT for UART in SABRE AI Quad CPU Card.

ソリューションへジャンプ
1,475件の閲覧回数
nishad_kamdar
Contributor IV

I am working on a custom iMX6q board resembling the SABRE  AI Quad CPU card.   I am trying to boot my board using the Parallel NOR Flash.   I have generated the uboot image for the WEIM NOR Flash for  the Sabre AI board, however,i have found out that my debug  UART is connected to the UART1 port of the Processor whereas  in the Sabre AI, the debug port is UART4.   I have gone through the Linux BSP porting guide, and the Linux  User guide, but i did not find anything which tells me how to  make changes in the Uboot code so that i can change the debug  UART port. Can anyone help me in make the modifications?

ラベル(2)
タグ(4)
1 解決策
635件の閲覧回数
cyborgnegotiato
Senior Contributor II

Hi,

You must looking for uboot porting guilds.

In your case, you want modify board specific file for setup correct UART - iomux setup (for example modify func setup_uart() in board/freescale/<board>/...). You can inspire in many board in uboot, for example Sabre iMX6QSDB use UART1 as output port (it will be easiest way for you, maybe). Do not forget change CONFIG_UART_BASE_ADDR to UART1_BASE_ADDR in your board specific config (include/configs/...)

Regards,

Jozef

元の投稿で解決策を見る

2 返答(返信)
636件の閲覧回数
cyborgnegotiato
Senior Contributor II

Hi,

You must looking for uboot porting guilds.

In your case, you want modify board specific file for setup correct UART - iomux setup (for example modify func setup_uart() in board/freescale/<board>/...). You can inspire in many board in uboot, for example Sabre iMX6QSDB use UART1 as output port (it will be easiest way for you, maybe). Do not forget change CONFIG_UART_BASE_ADDR to UART1_BASE_ADDR in your board specific config (include/configs/...)

Regards,

Jozef

635件の閲覧回数
nishad_kamdar
Contributor IV

Hey,

Thanks for the reply, after making the changes,  i was able to port U-Boot on my processor.

I have attached the Snapshot.

As you can see uboot has been able to bring up the DDR and Uart.

However, i have loaded the kernel in Parallel Nor flash.

As you can see, the Uboot has not been able to bring the NOR Flash up.

My parallel NOR flash is Spansion S29GL01GP.

I am running it in 16 bit mode.

I have connected the data lines to the Lower data bits of the EIM data bus in contrast to the SABRE AI board where the NOR flash is connected to the Higher order data bus.

I have modified the IOMUX in mx6_sabreauto.c (I am Using the Sabre AI Weimnor Uboot).

Kindly suggest the additional modifications to be done to bring the NOR Up.

Regards,

nishad

0 件の賞賛