LTIB "Failed building wget" undefined reference to `SSLv2_client_method'

cancel
Showing results for 
Search instead for 
Did you mean: 

LTIB "Failed building wget" undefined reference to `SSLv2_client_method'

10,680 Views
AdCmo
Contributor III

I was following the LTIB guide:

Ubuntu 11.10 Oneiric 64-bit Virtual Machine and building i.MX53 L2.6.35-11-09-01

I got past the zlib issues by following:

http://vijay496.blogspot.com/2012/03/ltib-for-ubuntu-1110-error-fac...


Now: I am having wget package failing.
I am running Ubuntu 11.10, 32-bit.

Anyone ever got the error below, thanks?
 

Ad.
-----------------

gcc -O2 -Wall -Wno-implicit -o wget cmpt.o connect.o convert.o cookies.o ftp.o ftp-basic.o ftp-ls.o ftp-opie.o hash.o headers.o host.o html-parse.o html-url.o http.o init.o log.o main.o gen-md5.o netrc.o progress.o rbuf.o recur.o res.o retr.o safe-ctype.o snprintf.o gen_sslfunc.o url.o utils.o version.o -lssl -lcrypto -ldl
gen_sslfunc.o: In function `init_ssl':
gen_sslfunc.c:(.text+0x351): undefined reference to `SSLv2_client_method'
collect2: ld returned 1 exit status
make[1]: *** [wget] Error 1
make[1]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/wget-1.9.1/src'
make: *** [src] Error 2
error: Bad exit status from /home/me/imx53/11.09.01/ltib/tmp/rpm-tmp.33663 (%build)


RPM build errors:
Bad exit status from /home/me/imx53/11.09.01/ltib/tmp/rpm-tmp.33663 (%build)
Build time for wget: 21 seconds

Failed building wget
Died at ./ltib line 1380.
traceback:
main::build_host_rpms:1380
main::host_checks:1435
main:542


Started: Mon May 21 00:16:07 2012
Ended: Mon May 21 00:16:28 2012
Elapsed: 21 seconds

These packages failed to build:
wget 

Build Failed

Labels (1)
14 Replies

705 Views
narreddisivapra
Contributor II

Please reply

0 Kudos

705 Views
IvicaEftimovski
Contributor III

I am not sure what do you mean by having SSL installed? Do you have it installed on the LTIB platform or on your Ubuntu?

OpenSSL is a part of the LTIB distribution, so try compiling it from there for your iMX target and see if you get the wget error again.

0 Kudos

705 Views
jonathanben-avr
Contributor II

Debian and Ubuntu openssl distro packages are built with -DOPENSSL_NO_SSL2, i.e. SSLv2 disabled. To enable, you need either to compile wget without SSL at all, or compile openssl from source yourself. Here are the directions to compile openssl yourself:

  1. Download openssl-1.0.1f.tar.gz from http://www.openssl.org/source/openssl-1.0.1f.tar.gz
  2. Open the OpenSSL tarball: yba@tavas:/usr/local/src# zcat openssl-1.0.1f.tar.gz | tar xvf -
  3. pushd openssl-1.0.1f/
  4. ./config shared
  5. make
  6. sudo make install
  7. In ltib installation directory do export LDFLAGS=-L/usr/local/ssl/lib; export CPPFLAGS=-I/usr/local/ssl/include
  8. ./ltib

Note that you might have to do rm -rf  /opt/freescale/ltib/usr/src/rpm/BUILD/wget-1.9.1 if the wget build already failed.

705 Views
calvinmoore
Contributor II

This solution only worked if instead of step 7, I executed `export LDFLAGS=-L/usr/local/ssl/lib`

0 Kudos

705 Views
trinhkhai
Contributor II

This worked... thanks for helping

0 Kudos

705 Views
xray
Contributor III

This worked for me.  I wish I could mark it as the right answer, but only the poster can do that...

0 Kudos

705 Views
AdCmo
Contributor III

Ivica,


I tried both and only disabling SSL in the spec file worked.

I am worried some automated scripts that use wget will break if they try

to get from https sites :(


But that is a different issue.


Thanks,

Ad.

............

0 Kudos

705 Views
jaysonwu
Contributor I

Hi

By saying "disabling SSL in the spec file worked". How did you managed to disable it?

Thanks,

Jayson

0 Kudos

705 Views
jasonjiang
Contributor II

In the file /ltib/dist/lfs-5.1/wget/wget.spec, at line “./configure”, add “--without-ssl”

705 Views
AdCmo
Contributor III

Do I need to compile OpenSSL maually or apt-get will do?

I do have openssl installed but I can't find any plain developer version

when I do l "sudo aptitude search openssl".

Thanks,

Ad.

-----------------------


Ivica Eftimovski said:

I think you have two choices here:

1. Disable SSL by adding “--without-ssl” to the configure line in the *.spec  file.
2. Compile OpenSSL. I think this is the only external SSL library that wget works with.

0 Kudos

705 Views
IvicaEftimovski
Contributor III

I think you have two choices here:

1. Disable SSL by adding “--without-ssl” to the configure line in the *.spec  file.
2. Compile OpenSSL. I think this is the only external SSL library that wget works with.

705 Views
narreddisivapra
Contributor II

hi,

Already "--without-ssl" is there in wget.spec file and even I installed OpenSSL, it is giving same issue "Failed building wget-ssl ".

Help me in solving this issue.

Thanks and regards,

Siva Prakash Reddy N

0 Kudos

705 Views
jimmychan
NXP TechSupport
NXP TechSupport

have you remove the wget folder under rpm/BUILD/ first? then try to build it again.

0 Kudos

705 Views
narreddisivapra
Contributor II

Hi,

     I had build ltib and configured successfully. While configuration, I had selected helloworld(already given by ltib) module but how can I check module installed or not through console view?  I logged into kernel and searched through lsmod command, but i didn't get any module list?
Thanks&Regards,
Siva Prakash.
0 Kudos