LCD turning white after a few minutes

cancel
Showing results for 
Search instead for 
Did you mean: 

LCD turning white after a few minutes

Jump to solution
2,011 Views
erezsteinberg
Contributor IV

Hi all-

I have some strange behavior on my board and LCD

It's a custom iMX6S board running Linux 3.0.35. The display is a parallel LCD (8-bit) using BT656 protocol.

After booting, I display an image on the LCD. After a few minutes the display suddenly becomes white. At that point, if I try to display a new image nothing happens.

However, if I do "echo 0 > /sys/devices/platform/mxc_sdc_fb.0/graphics/fb0/blank", then I can display images again. But, again, after a few minutes the LCD turns white.

Any ideas what might be causing the LCD to 'turn white' by itself?

Sincerely,

Erez

Labels (3)
Tags (1)
1 Solution
697 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Erez

one can try to turn off LCD blanking also with

echo -e "\033[9;0]" > /dev/tty0

https://community.freescale.com/message/432351#432351

Best regards

igor

View solution in original post

0 Kudos
2 Replies
698 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Erez

one can try to turn off LCD blanking also with

echo -e "\033[9;0]" > /dev/tty0

https://community.freescale.com/message/432351#432351

Best regards

igor

0 Kudos
697 Views
erezsteinberg
Contributor IV

Hi Igor,

Thanks -- that solved the issue.

I found this resource with additional useful commands --- http://www.armadeus.com/wiki/index.php?title=FrameBuffer

For anyone looking::

  • To stop blinking cursor:

# echo 0 > /sys/class/graphics/fbcon/cursor_blink

also possible at boot time (with 3.x recent kernels):

BIOS> setenv extrabootargs vt.global_cursor_default=0 
  • To make it blinking again:
 # echo 1 > /sys/class/graphics/fbcon/cursor_blink 
  • To grab a screenshot of a running Framebuffer application, use FBGrab
  • To enter in Framebuffer sleep mode:

# echo 1 > /sys/class/graphics/fb0/blank

  • To leave Framebuffer sleep power mode:
 # echo 0 > /sys/class/graphics/fb0/blank 
  • To set "sleep mode"/screensaver entering time (where X is a time in minute; 0 = never):

# echo -e '\033[9;X]' > /dev/tty1 (from serial console)

or

 # echo -e '\033[9;X]'    (from framebuffer console) 

or to set it at each boot, use /etc/inittab:

 tty1::sysinit:echo -e '\033[9;X]' 

Other usefull ESC sequences

  • To (definitly) hide cursor:
 # echo -e '\033[?17;0;0c' > /dev/tty1    (from serial console) 

or

 # echo -e '\033[?17;0;0c'    (from framebuffer console) 
  • inverse screen on:

# echo -e '\033[?5h' > /dev/tty1

  • inverse screen off:
 # echo -e '\033[?5l' > /dev/tty1

Regards,

Erez