IMX8MQ Kernel downgrade 5.10 -> 5.4 in imx AOSP source code

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX8MQ Kernel downgrade 5.10 -> 5.4 in imx AOSP source code

Jump to solution
205 Views
chaitanyaarur
Contributor II

Hi Everyone, 

In IMX8M quad board,  source code build of android 11 is successful.

https://www.nxp.com/webapp/Download?colCode=11.0.0_2.0.0_ANDROID_SOURCE&appType=license

Kernel version 5.10 used in above source code.

How to downgrade kernel to 5.4 with Android 11 in imx.(Because, 1CX bluetooth is supported till linux 5.4.24)?

Please suggest.

0 Kudos
1 Solution
177 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi,

You mean you need CYW4356 driver in L5.4.24_2.1.0. Actually you don’t need downgrade android kernel, continue to use your current android version. Then, you need to ask Cypress or Murata for these materials:
1. linux driver source code and firmware of 1CX.
2. Cross compile linux driver and port it to the android
3. Unlike linux, BT requires android HAL code, which needs to be provided by Cypress.

 

Have a good day!

Regards,

weidong

View solution in original post

4 Replies
178 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi,

You mean you need CYW4356 driver in L5.4.24_2.1.0. Actually you don’t need downgrade android kernel, continue to use your current android version. Then, you need to ask Cypress or Murata for these materials:
1. linux driver source code and firmware of 1CX.
2. Cross compile linux driver and port it to the android
3. Unlike linux, BT requires android HAL code, which needs to be provided by Cypress.

 

Have a good day!

Regards,

weidong

View solution in original post

127 Views
chaitanyaarur
Contributor II

Hi @weidong_sun,

Thank you very much for support.

We are checking for suggested details from cypress.

https://community.cypress.com/t5/Wireless/IMX8MQ-1CX-CYW4356-drivers-LF5-10-9-1-0-0-kernel-Android-1...

We are in short of time. Is there any simple workaround for Bluetooth bring up using CYW4356 in Android 11?.

 

Regards,

Chaitanya.A. 

Tags (1)
0 Kudos
192 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi,

you can check android_11.0.0_1.0.0, whose kernel version is L5.4.47_2.2.0

weidong_sun_0-1631156370530.png

Have a good day!

Regards,

weidong

 

186 Views
chaitanyaarur
Contributor II

Hi weidong,

 

In L5.4.47_2.2.0 on board chip support is not provided. Please refer Section 11 Connectivity.

https://www.nxp.com/webapp/Download?colCode=L5.4.47_2.2.0_LINUX_DOCS

 

It is supported upto L5.4.24_2.1.0. Please refer Section 10 Connectivity.

https://www.nxp.com/webapp/Download?colCode=L5.4.24_2.1.0_LINUX_DOCS

 

This is the reason for asking kernel downgrade procedure in AOSP source code.

Please check and provide your inputs.

 

Note: Based on your inputs, we have flashed android_11.0.0_1.0.0, bluetooth is not working. 

 

Regards,

Chaitanya.A.

0 Kudos