[IMX8MP] uuu download stuck and "USB init failed: -22"

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

[IMX8MP] uuu download stuck and "USB init failed: -22"

跳至解决方案
2,685 次查看
sophiehu
Contributor III

Hi NXP,

Our board has done DDR tools and verify with SDK imx-5.10.9, and it flash with dd command. However , it cannot boot successfully by flashing with dd command for SDK imx-5.10.72-2.2.0 and you told me to flash by uuu.
https://community.nxp.com/t5/i-MX-Processors/i-MX8M-Plus-boot-from-sdcard-fail/m-p/1421722#M187673

So I test with EVK first.
I flash release image dwonload from NXP successfully with uuu to EVK and sdcard on EVK.
Then I repo SDK imx-5.10.72-2.2.0, build full image, flash built files (imx-boot-imx8mpevk-sd.bin-flash_evk and imx-image-full-imx8mpevk.wic.bz2) with uuu to EVK successfully.

Now I merge what we modified for DDR of u-boot before in SDK imx-5.10.72-2.2.0.
..\tmp\work\imx8mpevk-poky-linux\u-boot-imx\1_2020.04-r0\git\include\configs\imx8mp_evk.h (diff as attached diff.txt)
..\tmp\work\imx8mpevk-poky-linux\u-boot-imx\1_2020.04-r0\git\board\freescale\imx8mp_evk\lpddr4_timing.c (as attached lpddr4_timing.c)

Build new image and try to flash new built files in our board.
It stuck after flashing bootloader.

[UUU command window]

D:\tool\development\uuu>uuu -d D:\Project\imx8mp\LF_v5.10.72-2.2.0_images_IMX8MPEVK\uuu.sophie_01_uboot.auto
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.165-0-ge10b026

Success 0 Failure 0


1:21 1/ 1 [=================100%=================] SDPS: boot -f imx-boot-imx8mpevk-sd.bin-flash_evk-20220309100344

[debug messages of our board]

U-Boot SPL 2021.04-lf_v2021.04+g263b27e076 (Nov 22 2021 - 01:39:23 +0000)
DDRINFO: start DRAM init
DDRINFO: DRAM rate 3000MTS
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
SEC0: RNG instantiated
Normal Boot
WDT: Not found!
Trying to boot from BOOTROM
Find img info 0x&480265a0, size 1032
Need continue download 1024
Download 1595520, Total size 1597152
NOTICE: BL31: v2.4(release):lf-5.10.72-2.2.0-0-g5782363f9
NOTICE: BL31: Built : 12:17:17, Nov 18 2021


U-Boot 2021.04-lf_v2021.04+g263b27e076 (Nov 22 2021 - 01:39:23 +0000)

CPU: i.MX8MP[6] rev1.1 1600 MHz (running at 1200 MHz)
CPU: Industrial temperature grade (-40C to 105C) at 40C
Reset cause: POR
Model: NXP i.MX8MPlus LPDDR4 EVK board
DRAM: 2 GiB
tcpc_init: Can't find device id=0x50
setup_typec: tcpc port2 init failed, err=-19
tcpc_init: Can't find device id=0x50
setup_typec: tcpc port1 init failed, err=-19
MMC: FSL_SDHC: 1, FSL_SDHC: 2
[*]-Video Link 0adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19

[0] lcd-controller@32e80000, video
[1] mipi_dsi@32e60000, video_bridge
[2] adv7535@3d, panel
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19
In: serial
Out: serial
Err: serial
SEC0: RNG instantiated

BuildInfo:
- ATF 5782363

MMC: no card present
Detect USB boot. Will enter fastboot mode!
Net:
Warning: ethernet@30be0000 (eth0) using random MAC address - c2:e0:73:54:17:61

Warning: ethernet@30bf0000 (eth1) using random MAC address - 0a:e3:0c:fc:ce:6e
eth0: ethernet@30be0000, eth1: ethernet@30bf0000 [PRIME]
Fastboot: Normal
Boot from USB for mfgtools
*** Warning - Use default environment for mfgtools
, using default environment

Run bootcmd_mfg: run mfgtool_args;if iminfo ${initrd_addr}; then if test ${tee} = yes; then bootm ${tee_addr} ${initrd_addr} ${fdt_addr}; else booti ${loadaddr} ${initrd_addr} ${fdt_addr}; fi; else echo "Run fastboot ..."; fastboot 0; fi;
Hit any key to stop autoboot: 0

## Checking Image at 43800000 ...
Unknown image format!
Run fastboot ...
USB init failed: -22
u-boot=>

In our hw design, USB1 connects to hub by default.

sophiehu_0-1646906150849.png

If we want to use uuu, hw engineer will disconnect the connection of USB1_DP and USB2_DP and make it connect to a connector to normal usb 2.0 port. (remove R225 and R226, add R156 and R157) Remain else USB1 pins connecting to hub.

sophiehu_1-1646906224526.png

It is OK for DDR tool.
But is it OK for uuu download? Does uuu download need usb 3.0? Or how can I modify uboot for this usb design?

Best Regards,
Sophie

0 项奖励
回复
1 解答
2,672 次查看
BiyongSUN
NXP Employee
NXP Employee

It is very clear you haven't finished the porting according to the custom board. 

This board should have no typec hardware design or different typec hardware design as i.MX8MP evk does.

 

 

tcpc_init: Can't find device id=0x50
setup_typec: tcpc port2 init failed, err=-19
tcpc_init: Can't find device id=0x50
setup_typec: tcpc port1 init failed, err=-19

在原帖中查看解决方案

0 项奖励
回复
1 回复
2,673 次查看
BiyongSUN
NXP Employee
NXP Employee

It is very clear you haven't finished the porting according to the custom board. 

This board should have no typec hardware design or different typec hardware design as i.MX8MP evk does.

 

 

tcpc_init: Can't find device id=0x50
setup_typec: tcpc port2 init failed, err=-19
tcpc_init: Can't find device id=0x50
setup_typec: tcpc port1 init failed, err=-19

0 项奖励
回复