I can not build u-boot-fw-utils in yocto for maaxboard from imx8mq_evk.

cancel
Showing results for 
Search instead for 
Did you mean: 

I can not build u-boot-fw-utils in yocto for maaxboard from imx8mq_evk.

59 Views
gonewithwind-peter
Senior Contributor I

Hi all,

I am playing rauc. there are two rootfs to boot.
so need to change uboot environment variables to switch boot between the first rootfs and redundant rootfs.
so need to add IMAGE_INSTALL_append +="u-boot-fw-utils " in yocto local file to enable fw_printenv, fw_setenv.
but bitbake can not pass build u-boot-fw-utils. it shows can find maaxboard_defconfig. so I use imx8mq_evk_defconfig to instead it.
it can pass building. but after bootup, I run fw_printenv , it shows error : can not find /dev/mtd1. and can not find /dev/mtd either
before I did not add IMAGE_INSTALL_append +="u-boot-fw-utils " , of course, there was not command fw_printenv. but it could find /dev/mtd ,only no content.

My questions are :

1.

I want to know do I can use fw_printenv ? or Can I use uEnv.txt to change uboot environment variables to switch boot the two rootfs' ?

2. because there is no  file "maaxboard_defconfig" in "u-boot-fw-utils " to fit maaxboard, but there is a file imx8mq_evk_defconfig , how can I modify the file   imx8mq_evk_defconfig  to  maaxboard_defconfig to make u-boot-fw-utils can be built and make fw_printenv   to work? what are the porting points?

 

any help?

Thank you very much.

0 Kudos
4 Replies

51 Views
Qmiller
NXP Employee
NXP Employee
0 Kudos

27 Views
gonewithwind-peter
Senior Contributor I

Hi 

@Qmiller 

I can build u-boot-fw-utils successfully.Thank you very much.

I have one more question here:

uboot environment variable should be written in which partition on sdcard?

https://community.nxp.com/t5/i-MX-Processors/uboot-environment-should-be-written-in-which-partition-...

please have a look.

Thank you.

Tags (1)
0 Kudos

42 Views
gonewithwind-peter
Senior Contributor I
Hi Qmiller,
I follow the link guid to use uboot-imx source code to replace uboot source code, so it should use uboot-imx defcong to compile the u-boot-fw-utils. It can pass compile and generate fw_printenv .
but after running fw_printenv ,the same error happened.
what 's wrong with it?
there are totally no device node mtd, mtd1, mtd2 ...
let me try recipe patch later(I think do not need to add the recipe patch. it should work well)
------
fw_printenv
Cannot open /dev/mtd1: No such file or directory
0 Kudos

46 Views
gonewithwind-peter
Senior Contributor I
thank you very much. let me have a look
0 Kudos