How to apply new patch to old BSP

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

How to apply new patch to old BSP

1,001件の閲覧回数
jasonhsu
Contributor III

Hi Community,

For some aging test issues, I have to apply new patch to old BSP. However, the BSP version on which is the patch based is newer than the BSP I used, if I use the new patch, many conflicts will appear and cannot be fixed manually, because some data structs do not exist at all in old BSP.

We create project last year based on the BSP (IMX6_JB43_110_ANDROID_SOURCE_BSP), see below picture.

16809_16809.jpg1.jpg

and now, I  have to apply new patch (IMX6_JB43_111_ANDROID_SOURCE_BSP) according to FSL FAE suggest, see below picture:

16810_16810.jpg1.jpg

If apply IMX6_JB43_111_ANDROID_SOURCE_BSP to (IMX6_JB43_110_ANDROID_SOURCE_BSP) directly, it will generate many patch failure in kernel_imx. and cannot fix manually, because some data structs do not exist at all.

Could someone teach me how to apply patch based on IMX6_JB43_111_ANDROID_SOURCE_BSP to  (IMX6_JB43_110_ANDROID_SOURCE_BSP) ? many many thxs.

the aging test issue i encouter: Re: Re: Re: V4L2, encoding seems not work.

Best regards,

Jianhua

ラベル(2)
タグ(2)
0 件の賞賛
返信
1 返信

791件の閲覧回数
gusarambula
NXP TechSupport
NXP TechSupport

The JB4.3.0_1.1.1 BSP is not a formal release but a series of patches to be applied on the previous release. Which steps are you following in order to apply these? Please look at section 3.2 of the Android User’s Guide.

It could be possible that some errors occur if modifications were made on the original JB4.3.0_1.1.0. Have you changed the original BSP?

0 件の賞賛
返信