Enable systemd-time-wait-sync.service in rootfs image

cancel
Showing results for 
Search instead for 
Did you mean: 

Enable systemd-time-wait-sync.service in rootfs image

Jump to solution
61 Views
dvlogic
Contributor II

I have a service that requires time being set.  By googling around I found that the "systemd-time-wait-sync.service" is responsible for letting the system know when time is set.  

I have a systemd service with the following unit requirements:

[Unit]
Description=My Service
After=network-online.target
After=time-sync.target
Wants=time-sync.target

I see that the systemd-time-wait-sync service is installed but its not enabled.  If I don't have systemd-time-wait-sync.service enabled, my service runs even if time is not set (and for that matter network isn't online).  However, if I manually enable the systemd-time-wait-sync.service, my service works and will not run until time is actually set, after we get the network online.

How do I make the systemd-time-wait-sync.service enabled at install time? (e.g. automatically create the symbolic link to the /etc/systemd/system/sysinit.target.wants?

Thanks.

0 Kudos
1 Solution
57 Views
dvlogic
Contributor II

Never mind, I figured it out.  I had to add a "Wants=systemd-time-wait-sync.service" to my service Unit settings.  

View solution in original post

0 Kudos
2 Replies
46 Views
b36401
NXP TechSupport
NXP TechSupport

Thanx for letting us know. I'm closing the case.

0 Kudos
58 Views
dvlogic
Contributor II

Never mind, I figured it out.  I had to add a "Wants=systemd-time-wait-sync.service" to my service Unit settings.  

View solution in original post

0 Kudos