Busybox httpd: error 501 on POST request and cgi not executing on yocto linux-3.10.53

取消
显示结果 
搜索替代 
您的意思是: 
已解决

Busybox httpd: error 501 on POST request and cgi not executing on yocto linux-3.10.53

跳至解决方案
1,255 次查看
justthat1
Contributor II

Hello everyone,

I'm trying to set-up a lightweight web-server on a custom board based on an IMX6Q processor with linux 3.10.53 as OS. I've built the OS using the Yocto software.

I can see the html pages hosted on my board through the browser, though whenever I send an HTTP POST request I get as response the error "501 Not Implemented The requested method is not recognized".

Also when I send an HTTP GET request, the browser downloads the executable instead of running it. All the executables (that, as a test, only print plain strings in html fashion; source files are written in C code) are placed under the "cgi-bin" directory of the web-server home directory. I made sure to have changed their owner and permissions and, in fact, I can run them just fine from the board terminal.

Thanks for your help

edit - Found the culprit: the httpd service build by busybox in the yocto software doesn't enable the cgi by default. I had to manually enable it, by using "bitbake busybox -c menuconfig" and checking the flag for cgi support in the "networking utilities" menu

标签 (4)
0 项奖励
1 解答
678 次查看
justthat1
Contributor II

Found the culprit: the httpd service build by busybox in the yocto software doesn't enable the cgi by default. I had to manually enable it, by using "bitbake busybox -c menuconfig" and checking the flag for cgi support in the "networking utilities" menu

在原帖中查看解决方案

0 项奖励
1 回复
679 次查看
justthat1
Contributor II

Found the culprit: the httpd service build by busybox in the yocto software doesn't enable the cgi by default. I had to manually enable it, by using "bitbake busybox -c menuconfig" and checking the flag for cgi support in the "networking utilities" menu

0 项奖励