Burning Linux uImage into i.MX53 QSB

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

Burning Linux uImage into i.MX53 QSB

1,179 次查看
brahman_river
Contributor I

Now I'm trying to burn Linux uImage I built into i.MX53 QSB. After executing tftpboot, however, any key input is not accepted.

-------------------------------------------------------------------

MX53-LOCO U-Boot > tftpboot 0x00020000 uImage FEC: enable RMII gasket PHY indentify @ 0x0 = 0x0007c0f1 Using FEC0 device TFTP from server 172.16.1.15; our IP address is 172.16.15.45 Filename 'uImage'. Load address: 0x20000 Loading: FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

FEC: Link is down 7809

#

-------------------------------------------------------------------

I'm not sure if the file transfer was sucessfully completed. It seems weird that the left side of RJ-45 LED was blinking all the way. 

 

I also tried to loadb command to send the image via serial I/F, but it didn't also make progress after just 2 bytes were transferred.
Can environment variable have something to do with this failure? I attach an file showing all the variables. Does anyone have an idea?
Best Regards,
Takashi Kawamoto
标签 (1)
0 项奖励
回复
2 回复数

864 次查看
brahman_river
Contributor I

Hi, 

As long as I see the sniffer log, Just a block of data is sent from TFTP server after i.MX53 QSB send Read Request, and no more data is transferred.

0 项奖励
回复

864 次查看
PhilEndecott
Contributor II
If I were you, I'd run wireshark on the server.
0 项奖励
回复