Bitbake not working

キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
3,267件の閲覧回数
VinithNama
Contributor III

Hi,

      When i have build the complete booting process in Linux for imx8m mini EVK in the same build terminal the bitbake command works properly. when I have shutdown the Linux machine and I'm again turning on the PC at the time it throwing an exception bitbake command not found .

0 件の賞賛
1 解決策
3,242件の閲覧回数
VinithNama
Contributor III

Thanks for your information,  it works for me

元の投稿で解決策を見る

0 件の賞賛
6 返答(返信)
3,253件の閲覧回数
turker
Contributor IV

You need to source environment setup scripts everytime you boot your PC or switch to another terminal.

タグ(1)
0 件の賞賛
3,249件の閲覧回数
VinithNama
Contributor III

I doesn't have any idea about how to source can you help me how to source 

0 件の賞賛
3,245件の閲覧回数
turker
Contributor IV

It is available in the README.

Run i.MX Linux Yocto Project Setup:
$: [MACHINE=<machine>] [DISTRO=fsl-imx-<backend>] source ./imx-setup-release.sh -b <build folder>

In my case I run:

MACHINE=imx8mmevk DISTRO=fsl-imx-xwayland source imx-setup-release.sh -b build/

0 件の賞賛
3,243件の閲覧回数
VinithNama
Contributor III

Thanks for your information,  it works for me

0 件の賞賛
3,262件の閲覧回数
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello VinithNama,

If you have building and flashing correctly the MX8MM, then your problem is the host.

 

Regards

 

 

0 件の賞賛
3,259件の閲覧回数
VinithNama
Contributor III

Hi,

     Currently I'm using ubuntu 18.04 for building the image and i am able to flash through sd card .When I'm going to compile the device tree after rebooting the linux pc using  bitbake -c compile -f linux-imx it shows bitbake not found.

 

 

Thanks & Regards,

Vinith.

0 件の賞賛