Task #1 - Download the source code

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Task #1 - Download the source code

Task #1 - Download the source code

Yocto Project versions and names

See here the list of all yocto version names: Releases - Yocto Project 

The current stable release is Zeus

Preparing host environment

For virtual machine (VirtualBox):

Please set memory size minimal to 1GB and disk size to 32GB. (24Feb2014 Ubuntu 12.04LTS)


First, make sure your host PC has the required packages to run Yocto

The essential packages you need for a supported Ubuntu distribution are shown in the following command:

$ sudo apt-get build-dep qemu
$ sudo apt-get remove oss4-dev
$ sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib \
  build-essential chrpath socat cpio python python3 python3-pip python3-pexpect \
  xz-utils debianutils iputils-ping python3-git python3-jinja2 libegl1-mesa libsdl1.2-dev \

For other Linux distribution or newer Yocto Project release see here the updated list.

Download the source code from community

Install the repo

$ sudo apt-get install repo‍‍‍

Download the BSP source:

$ mkdir fsl-community-bsp
$ cd fsl-community-bsp
$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b zeus
$ repo sync‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍

Download the source code from NXP Code Aurora

See here the list of all BSP releases from NXP: imx-manifest - i.MX Release Manifest 

Currently, the latest NXP release how to is here: README - imx-manifest - i.MX Release Manifest 

To understand the difference between the 2 source code (community X NXP BSP) see here

Go to https://community.nxp.com/docs/DOC-94849 

Go to Task #2

Labels (1)


what do you think if we use the word 'Download' instead of 'Take'? Or even 'Obtain'? it is just a semantic opinion :smileyhappy:


Thanks a lot :smileywink:

I would write:

""First, make sure your host PC has the required packages to run Yocto""


On fedora there is no eglibc-devel only glibc-devel


Thanks Ajay, I´m going to fix my doc.

I use Ubuntu only, so please, keep doing the tasks and please, keep reporting any issue you face! It will help a lot of other people that may follow it in future :smileywink:

For Ubuntu (12.04), I needed to install "curl". (sudo apt-get install curl)

Maybe you can add it, in the first section.




when I remember right, for my Gentoo it was

'emerge sys-devel/gettext media-libs/libsdl dev-util/diffstat dev-vcs/git'

Hi Daiane,

Really useful article - Thanks. However, I have a problem - when I do the "repo init" step, I get lots of good things happening, but also an error:

curl: (22) The requested URL returned error: 404 Not Found

Server does not provide clone.bundle; ignoring.

Any ideas what is happening here? Full command / response shown below:

dchirgwin@dc-ubuntu2:~/fsl-community-bsp$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dylan

Get https://gerrit.googlesource.com/git-repo

remote: Counting objects: 101, done

remote: Finding sources: 100% (101/101)

remote: Total 2533 (delta 1442), reused 2533 (delta 1442)

Receiving objects: 100% (2533/2533), 1.71 MiB | 813 KiB/s, done.

Resolving deltas: 100% (1442/1442), done.

From https://gerrit.googlesource.com/git-repo

* [new branch]      maint      -> origin/maint

* [new branch]      master     -> origin/master

* [new branch]      stable     -> origin/stable

* [new tag]         v1.0       -> v1.0

* [new tag]         v1.0.1     -> v1.0.1

* [new tag]         v1.0.2     -> v1.0.2

* [new tag]         v1.0.3     -> v1.0.3

* [new tag]         v1.0.4     -> v1.0.4

* [new tag]         v1.0.5     -> v1.0.5

* [new tag]         v1.0.6     -> v1.0.6

* [new tag]         v1.0.7     -> v1.0.7

* [new tag]         v1.0.8     -> v1.0.8

* [new tag]         v1.0.9     -> v1.0.9

* [new tag]         v1.1       -> v1.1

* [new tag]         v1.10.0    -> v1.10.0

* [new tag]         v1.10.1    -> v1.10.1

* [new tag]         v1.10.2    -> v1.10.2

* [new tag]         v1.10.3    -> v1.10.3

* [new tag]         v1.10.4    -> v1.10.4

* [new tag]         v1.11.0    -> v1.11.0

* [new tag]         v1.11.1    -> v1.11.1

* [new tag]         v1.12.0    -> v1.12.0

* [new tag]         v1.12.1    -> v1.12.1

* [new tag]         v1.12.2    -> v1.12.2

* [new tag]         v1.2       -> v1.2

* [new tag]         v1.3       -> v1.3

* [new tag]         v1.3.1     -> v1.3.1

* [new tag]         v1.3.2     -> v1.3.2

* [new tag]         v1.4       -> v1.4

* [new tag]         v1.4.1     -> v1.4.1

* [new tag]         v1.4.2     -> v1.4.2

* [new tag]         v1.4.3     -> v1.4.3

* [new tag]         v1.4.4     -> v1.4.4

* [new tag]         v1.5       -> v1.5

* [new tag]         v1.5.1     -> v1.5.1

* [new tag]         v1.6       -> v1.6

* [new tag]         v1.6.1     -> v1.6.1

* [new tag]         v1.6.10    -> v1.6.10

* [new tag]         v1.6.10.1  -> v1.6.10.1

* [new tag]         v1.6.10.2  -> v1.6.10.2

* [new tag]         v1.6.2     -> v1.6.2

* [new tag]         v1.6.3     -> v1.6.3

* [new tag]         v1.6.4     -> v1.6.4

* [new tag]         v1.6.5     -> v1.6.5

* [new tag]         v1.6.6     -> v1.6.6

* [new tag]         v1.6.7     -> v1.6.7

* [new tag]         v1.6.7.1   -> v1.6.7.1

* [new tag]         v1.6.7.2   -> v1.6.7.2

* [new tag]         v1.6.7.3   -> v1.6.7.3

* [new tag]         v1.6.7.4   -> v1.6.7.4

* [new tag]         v1.6.7.5   -> v1.6.7.5

* [new tag]         v1.6.8     -> v1.6.8

* [new tag]         v1.6.8.1   -> v1.6.8.1

* [new tag]         v1.6.8.10  -> v1.6.8.10

* [new tag]         v1.6.8.11  -> v1.6.8.11

* [new tag]         v1.6.8.2   -> v1.6.8.2

* [new tag]         v1.6.8.3   -> v1.6.8.3

* [new tag]         v1.6.8.4   -> v1.6.8.4

* [new tag]         v1.6.8.5   -> v1.6.8.5

* [new tag]         v1.6.8.6   -> v1.6.8.6

* [new tag]         v1.6.8.7   -> v1.6.8.7

* [new tag]         v1.6.8.8   -> v1.6.8.8

* [new tag]         v1.6.8.9   -> v1.6.8.9

* [new tag]         v1.6.9     -> v1.6.9

* [new tag]         v1.6.9.1   -> v1.6.9.1

* [new tag]         v1.6.9.2   -> v1.6.9.2

* [new tag]         v1.6.9.3   -> v1.6.9.3

* [new tag]         v1.6.9.4   -> v1.6.9.4

* [new tag]         v1.6.9.5   -> v1.6.9.5

* [new tag]         v1.6.9.6   -> v1.6.9.6

* [new tag]         v1.6.9.7   -> v1.6.9.7

* [new tag]         v1.6.9.8   -> v1.6.9.8

* [new tag]         v1.7       -> v1.7

* [new tag]         v1.7.1     -> v1.7.1

* [new tag]         v1.7.2     -> v1.7.2

* [new tag]         v1.7.3     -> v1.7.3

* [new tag]         v1.7.3.1   -> v1.7.3.1

* [new tag]         v1.7.4     -> v1.7.4

* [new tag]         v1.7.4.1   -> v1.7.4.1

* [new tag]         v1.7.4.2   -> v1.7.4.2

* [new tag]         v1.7.4.3   -> v1.7.4.3

* [new tag]         v1.7.5     -> v1.7.5

* [new tag]         v1.7.6     -> v1.7.6

* [new tag]         v1.7.6.1   -> v1.7.6.1

* [new tag]         v1.7.7     -> v1.7.7

* [new tag]         v1.7.7.1   -> v1.7.7.1

* [new tag]         v1.7.7.2   -> v1.7.7.2

* [new tag]         v1.7.7.3   -> v1.7.7.3

* [new tag]         v1.7.7.4   -> v1.7.7.4

* [new tag]         v1.7.7.5   -> v1.7.7.5

* [new tag]         v1.7.7.6   -> v1.7.7.6

* [new tag]         v1.7.8     -> v1.7.8

* [new tag]         v1.7.8.1   -> v1.7.8.1

* [new tag]         v1.7.8.2   -> v1.7.8.2

* [new tag]         v1.8.0     -> v1.8.0

* [new tag]         v1.8.1     -> v1.8.1

* [new tag]         v1.8.2     -> v1.8.2

* [new tag]         v1.9.0     -> v1.9.0

* [new tag]         v1.9.1     -> v1.9.1

* [new tag]         v1.9.2     -> v1.9.2

* [new tag]         v1.9.3     -> v1.9.3

* [new tag]         v1.9.4     -> v1.9.4

* [new tag]         v1.9.5     -> v1.9.5

* [new tag]         v1.9.6     -> v1.9.6

Get https://github.com/Freescale/fsl-community-bsp-platform

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

curl: (22) The requested URL returned error: 404 Not Found

Server does not provide clone.bundle; ignoring.

remote: Counting objects: 90, done.

remote: Compressing objects: 100% (63/63), done.

remote: Total 90 (delta 27), reused 87 (delta 26)

Unpacking objects: 100% (90/90), done.

From https://github.com/Freescale/fsl-community-bsp-platform

* [new branch]      danny      -> origin/danny

* [new branch]      denzil     -> origin/denzil

* [new branch]      dylan      -> origin/dylan

* [new branch]      master     -> origin/master

* [new tag]         1.2        -> 1.2

* [new tag]         1.4        -> 1.4

Your identity is: David Chirgwin


If you want to change this, please re-run 'repo init' with --config-name

Testing colorized output (for 'repo diff', 'repo status'):

  black    red      green    yellow   blue     magenta   cyan     white

  bold     dim      ul       reverse

Enable color display in this user account (y/N)?

repo has been initialized in /home/dchirgwin/fsl-community-bsp

are you under a proxy?

In case you are having issues downloading the source.

The repo (from google) has been updated to:

curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo

see Repo release 1.12.4 for more information


Please update the instructions, with latest curl URL, save people a couple hours and the hair on their heads.


Thans a lot, petersuciu!

Hi everybody!

You wrote in your tutorial:

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dylan

Is it still recommended to use "dylan"? I heard about that "dora" would be a newer version with better support for the boards? (e.g. here: http://boundarydevices.com/yocto-dora-release-mx6/)

If dora is better we should update this part in the DOC above :smileyhappy:

dora is latest stable branch and was just formally released!

Thanks florianl :smileywink:

Hi Daiane,

Thanks for your Update - sadly the repo-command doesnt work :smileysad:

Maybe it has to be

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora


we are working with the Freescale SDB and want to change vom LTIB to YOCTO. So I found this great Yocto training.

I followed the tutorial step by step, but the

==> repo sync

does not work correctly.

I get the following errors:

fatal: Unable to look up github.com (port 9418) (Der Name oder Dienst ist nicht bekannt)

fatal: Unable to look up git.yoktoproject.org (port 9418) (Der Name oder Dienst ist nicht bekannt)

error: Cannot fetch meta-fsl-demos

I think it might be a firewall-item, but i´m not sure.

Is there any possibility to change from git://...... to http:// port 8080

Best Regards and thx in advance


'git.yoktoproject.org' does not exit, it should be 'git.yoctoproject.org'. Did you change something on the manifest file?


It worked on my side. Just tested one minute ago.

What error did you get?


repo init -u dora doesn't work

Outputs "unknown repository url: dora"


You are completely right, I´m sorry...


repo init -b dora


What was the solution for this?  I'm seeing the same issue.


change the repo provider URL


Initially I build image for 'imx6qsabresd' using Yocto and it works fine.

$ MACHINE=imx6qsabresd . ./setup-environment build

$  bitbake fsl-image-gui

Now, I want to do the same for  'wandboard-solo', so I run below commands:

$ MACHINE=wandboard-solo . ./setup-environment build

$  bitbake fsl-image-gui

I am seeing that again it is downloading some stuff. Will it download everything again ( 44GB) or only the difference ?


It downloads only the new content. Except if you delete the downloads directory.

Hello Daiane,

I try to download bsp.
so, when i tried repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora i got following error
curl: (22) The requested URL returned error: 404
Server does not provide clone.bundle; ignoring.
remote: Reusing existing pack: 147, done.
remote: Total 147 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (147/147), 21.69 KiB, done.
Resolving deltas: 100% (47/47), done.
But i continued and i did repo snc .

I downloaded about 42MB and its finished.

but as you described above it should be 238MB. so i dont think this is complete.

I have 1 more laptop which have virtual machine.

on that laptop when i tried
curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo

i did not get complete repo file. so i download it and put that on my folder. And again now when i tried
repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora on virtual machine i got following error.

fatal: cannot get https://gerrit.googlesource.com/git-repo/clone.bundle

fatal:error Tunnel connection failed: 407 Proxy Authorization Required.

so i tried to open  https://gerrit.googlesource.com/git-repo/clone.bundle link but i got not found message.

i tried export http_proxy and https_proxy but not successfull. for your kind information i working behind proxy as i am using company's network.

so can you suggest me something?

Please, make sure you have the right access for external network. Are you under a proxy? Are your http/https port open?

actually i tried this on my personal laptop at home and there also i got error.

curl: (22) The requested URL returned error: 404
Server does not provide clone.bundle; ignoring.

In office i work under a proxy and i set proxy as required. my port is also open.

and i have a right access for external network also.

let me try it here

It´s working for me.

I´m using the instructions from http://freescale.github.io/

Okay. that means there is something wrong with my proxy.

can you suggest me what steps can i take to download it successfully?

i tried your given link but i got curl:(22) error at repo sync -init step.

I had several errors regarding http and https mistakes on my local configuration.

inside repo you may see a URL, you may change http to https (or vice-versa) and try the one different than default.

OR, you can dowloand every metalayer one by one, using git clone, instead of using repo.

the manifest: https://github.com/Freescale/fsl-community-bsp-platform/blob/dora/default.xml

show you what to download and which branch to use.

i want it for cross compile qt5 HMI application.

I have a imx6qsabreauto board.
i want to flash this board.
i want to use it for infotainment.

i tried with http and https but its still not working. :smileysad:

are you using a updated repo file?

Have you tried "git clone" of each meta layer? (please, let me know if you know how to do it :smileywink:)

No i haven't try git clone and i don't know how to use git clone.:smileysilly:
i use this version
repo version v1.12.13
       (from https://gerrit.googlesource.com/git-repo)
repo launcher version 1.21

git version
Python 2.7.3 (default, Feb 27 2014, 19:58:35)
[GCC 4.6.3]

exactly the same I have.

oh...... do you have git installed????????????

(only to make sure)

(my python is 2.7.5+ and my git is, and my gcc is 4.8.1)

yes, ofcourse git is installed.

I have newest version of git..

apt-get install git
Reading package lists... Done
Building dependency tree      
Reading state information... Done
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

ok. So let´s try the git clone:


$ git clone git://git.yoctoproject.org/poky


$ git clone git://git.yoctoproject.org/meta-fsl-arm

let´s start with only 2, next step would include meta-qt5. But let´s start with a core-image-minimal at first.

please, let me know if it works

(oh, and I´m so sorry, but I don´t know how to configure networks)

git clone git://git.yoctoproject.org/poky
Cloning into 'poky'...
remote: Counting objects: 226330, done.
remote: Compressing objects: 100% (57269/57269), done.
remote: Total 226330 (delta 164862), reused 225517 (delta 164064)
Receiving objects: 100% (226330/226330), 100.81 MiB | 193 KiB/s, done.
Resolving deltas: 100% (164862/164862), done.

jigar@ubuntu:~/fsl-community-bsp$ git clone git://git.yoctoproject.org/meta-fsl-arm
Cloning into 'meta-fsl-arm'...
remote: Counting objects: 6917, done.
remote: Compressing objects: 100% (2582/2582), done.
remote: Total 6917 (delta 4165), reused 6788 (delta 4037)
Receiving objects: 100% (6917/6917), 37.29 MiB | 206 KiB/s, done.
Resolving deltas: 100% (4165/4165), done.

i tried for meta-openembedded, fsl-community-bsp-base , meta-fsl-arm-extra, meta-fsl-demos..

and now i have 6 directories as described.

Now what i have to do next? or is it finished and i can start task 2? :smileyconfused:

yes, you´re done and you can start task 2

from time to time, try to download repo again, and try to understand why you´re facing those errors. as repo are used for android there are SEVERAL foruns with SEVERAL repo errors. take your time and fix your env.

from yocto perpective, you don´t need repo to get things done. There is small differences when not using fsl community bsp, it´s the setup enviroment script (you should use that one from poky it´s oe-init-build-env (http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/oe-init-build-env)

And you must include all layers in your build/conf/bblayers.conf. Take a look here https://community.freescale.com/docs/DOC-94614

how your bblayers should look like.

i tried as a root user. and still i got when i initialized repo.

so, when i tried repo init -u https://github.com/Freescale/fsl-community-bsp-platform-b dora i got following error
curl: (22) The requested URL returned error: 404
Server does not provide clone.bundle; ignoring.

but i continued and there is no problem i think.

i downloaded about 238MB as you described. and later i changed ownership of fsl-community-bsp directory.

Thank you for your support.

No ratings
Version history
Last update:
‎09-10-2020 03:30 AM
Updated by: