QN9080DK 2Mphy setting

cancel
Showing results for 
Search instead for 
Did you mean: 

QN9080DK 2Mphy setting

79 Views
tpgurtpgur2
Contributor I

Hi. I am using QN9080-DK to send data to PC as Notification and do a plot with Matlab.
I want to set the BLE physical layer to 2M physical layer because high data transmission speed is required.

I am testing using the Wireless_Uart example and changed the gBleUseHSClock2MbpsPhy_c macro from 0 to 1 to set the 2M physical layer.

However, even though I changed the gBleUseHSClock2MbpsPhy_c macro to 1, the data transfer rate was the same. I checked the code to find out why the speed didn't change.

It seems to me that when the gBleUseHSClock2MbpsPhy_c macro is activated, Gap_LeSetPhy is called from the ble_conn_manager.c file and the gLeSetPhy function is called and set gLePhy2MFlag_c.

The strange thing is that if you look at the function as shown below, not only gLePhy2MFlag_c is set, but gLePhy1MFlag_c seems to be used as well.

(void)Gap_LeSetPhy(TRUE, 0, 0, gLePhy1MFlag_c | gLePhy2MFlag_c, gLePhy1MFlag_c | gLePhy2MFlag_c, 0);

Since gLePhy1MFlag_c does not seem to increase the speed, I deleted gLePhy1MFlag_c to not use 1M phy and changed the function as shown below.


(void)Gap_LeSetPhy(TRUE, 0, 0, gLePhy2MFlag_c, gLePhy2MFlag_c, 0);

However, this time QN9080-DK and PC did not have BLE connection.

What am I doing wrong here?
I wonder what exactly is the method for setting 2M physical and how to do it.

0 Kudos
1 Reply

63 Views
nxf56274
NXP TechSupport
NXP TechSupport

Hi, 

Please refer this link. You can also use the example  'private profile client' and 'private client server' to test the speed.

0 Kudos