NHS3152 SDKs installation bug with MCUxpresso (SDKs not supported).

cancel
Showing results for 
Search instead for 
Did you mean: 

NHS3152 SDKs installation bug with MCUxpresso (SDKs not supported).

627 Views
Pel
Contributor III

Hello NXP Team,

 

I'm currently trying to program a NHS3152 with MCUxpresso, but I can't seems to installed the SDKs for the NHS3152 correctly. The Error Pop-up is :

---------------------------------------------------------------------------

The following items are not supported or valid SDKs

[path..\release_mra2_nhs3152.zip]

--------------------------------------------------------------------------

I did some research, but I can't find a reason why. The SDKs that I want to installed is the NHS3152 SDK - v12.4 (release_mra2_nhs3152.zip file).

 

Kind regards.

Alexandre Pellerin.

0 Kudos
14 Replies

607 Views
Fabian_R
NXP TechSupport
NXP TechSupport

Thank you for letting us assist you in creating your solution. Could you please help me to rectify if you are using MCUXpresso or LPCXpresso? I know it’s a bit confusing that when you are at the LPCXpresso overview it says that you should use MCUXpresso. Our apology for this but, NHS3152 is only supported by LPCXpresso as said in the doc "NHS3xxx Getting Started" from ->  …release_mra2_8_1_nhs3100/docs/1000UM_NHS31xx_GettingStarted.pdf

Thank you for using our products, we really appreciate it!!

Best Regards,
Fabian
0 Kudos

597 Views
Pel
Contributor III

Hi Fabian,

 

Thanks for the instruction.

I downloaded LPCxpresso and open my SDKs successfully. I tried running the blinky example just to make sure that everything was ok and I'm block with the following error:

----------------------------------------------------------

Error in final launch sequence
Failed to execute MI command:
-exec-run
Error message from debugger back end:
Don't know how to run. Try "help target".
Don't know how to run. Try "help target".

------------------------------------------------------------

(also in a screen shot attached to my message)

 

I can't find a solution to it do you know what may cause this ?

 

Thanks again,

Alexandre Pellerin

0 Kudos

576 Views
driesmoors
NXP Employee
NXP Employee

Hi Alexandre,

Did you install the plugin? It is located In the SDK under tools/lpcxpresso/plugins.

How to do install that zip file is described in UM11153 "NTAG SmartSensor getting started: A guide to start developing using an NHS31xx". In the SDK under docs, chapter 2.2 "NHS31xx plugin".

 

Regards,
Dries.

0 Kudos

559 Views
Pel
Contributor III

Hello Dries,

Yes, I have the plugins installed.

At first I had a '--gdb-version error', so I pointed the debugger to a gdb.exe from another software. I tried to find the gdb.exe within the SDKs or LPC folders but couldn't find it. For the moment I think it may be that or a bug intrinsic to the LPCxpresso program on my PC.

Do you have any other ideas ? 

Thanks for your help,

Alexandre Pellerin.

0 Kudos

551 Views
driesmoors
NXP Employee
NXP Employee

Hi,

What steps did you take to import the NHS3152 SDK in your workspace? Can you also give a screenshot of your IDE?

Best,
Dries.

0 Kudos

547 Views
Pel
Contributor III

Hi,

I imported the .zip of the SDKs with the Import project(s) from the 'start here' window. I simply pointed the 'project archive (.zip)' section to the .zip of the SDKs (release_mra2_nhs3152.zip).

I attached the screenshot of my IDE.

Regards,

Alexandre Pellerin.

0 Kudos

518 Views
driesmoors
NXP Employee
NXP Employee

Hi,

The DGB debugger in your build configuration should say arm-none-eabi-gdb, which then refers to the file C:\path\to\LPCXpresso_8.2.2_650\lpcxpresso\tools\bin\arm-none-eabi-gdb.exe

driesmoors_1-1635517834211.png

Can you check?

Regards,
Dries.

0 Kudos

515 Views
Pel
Contributor III

Hello Dries,

 

When I follow the path I don't see the tools folder in the LPCXpresso one:

Pel_0-1635518599160.png

As for now I'm not using the arm-none-eabi-gdb.exe for my gdb debugger since I don't have access to it.

I'll try uninstall/reinstall-ing LPCXpresso. If it doesn't, is there a place where I can get the tools folder ? 

 

Thanks,

Alexandre Pellerin.

0 Kudos

514 Views
Pel
Contributor III

This is the LPCXpresso folder when I download LPCXpresso with the 'Installer: LPCXpresso v8.2.2 for Windows' :

Pel_0-1635519519909.png

(No tools folder)

0 Kudos

509 Views
driesmoors
NXP Employee
NXP Employee

Hi,

There is no other way to get the correct tooling, it must come together with the installer.
Can you check inside the lpcxpresso folder? There should be a tools folder one level deeper.

Best,
Dries.

0 Kudos

501 Views
Pel
Contributor III

Hello dries,

 

I found the tools folder and the arm-none-eabi-gdb and I pointed the debug option to it:

Pel_0-1635537906245.png

 

Here's the C/C++ application window where I changed gdb.exe

Pel_1-1635538237488.png

 

Unfortunately, I have the same error when I tried to debug the project:

Pel_2-1635538299422.png

 

(Sorry I missclicked 'accepted as solution ' when trying to Reply to you)

 

Regards,

Alexandre Pellerin.

0 Kudos

474 Views
Pel
Contributor III

Hello Team,

 

I tried to create a new workspace and regroup the SDK in the NXP folder to test if it was a path issue. It didn't work unfortunately.

When I tried to run the example project without any changes to the debugger, the following error appear:

Pel_0-1635783243269.png     Pel_3-1635783462591.png

 

When I tried to go to the '(NXP semiconductor) MCU application' this error pop-up:

Pel_1-1635783296606.png   Pel_2-1635783357043.png

 

 

If I run the debug after, the following error stop it:

 

Exception

 

Reasons:

Error from StubMonCapabilities: -interpreter-exec console "mon capabilities": msg=""monitor" command not supported by this target."

 

 

I not sure how to interpret it.

 

Regards,

Alexandre Pellerin.

0 Kudos

608 Views
Pel
Contributor III

Hi again,

 

I manage to install other SDKs in the MCUxpresso IDE (SW368227.zip for example). So I thought it was a version thing or maybe I didn't download the right file, but after some research I always end up with the release_mra2_nhs3152.zip file for the SDKs of the NHS3152.

Is this the right SDKs for the NHS3152 kit? If not do you have a link to it ?

 

Thanks,

Alexandre Pellerin.

0 Kudos

260 Views
Fabian_R
NXP TechSupport
NXP TechSupport

Hello Alexandre,

Yes, this is the correct file for download the newest version is v12.4. You can check it in the next link: https://www.nxp.com/products/rfid-nfc/nfc-hf/ntag-smartsensor/ntag-smartsensor-with-temperature-sens... Section Embedded Software.

 

Best Regards,
Fabian
0 Kudos