Can't receive multicast packet when promisc mode is set in IW416

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't receive multicast packet when promisc mode is set in IW416

Jump to solution
304 Views
EthanHP_Tsai
Contributor II

Hi, 

I am working on IW416, and found following problem.

As WIFI client,

  • When promisc mode is set, can't receive any multicast packet from mlan0.
  • When promisc mode is unset, it is ok to receive multicast packet from mlan0.

How can I receive multicast packets in promisc mode?

Here is some information.

 

 

insmod /lib/modules/mlan.ko
insmod /lib/modules/moal.ko cfg80211_wext=0xf fw_name=sdiouartiw416_combo_v0.bin cal_data_cfg=none

# mlanutl mlan0 version
Version string received: SDIW416---16.92.21.p11.2-MM5X16283.p2-GPL-(FP92)

 

 

Thanks,
Ethan

Tags (3)
0 Kudos
1 Solution
216 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @EthanHP_Tsai,

Looking internally, the FP92 doesn't support the promisc mode. 

Sorry for the inconvenience this may cause you.

BR,

Alexis Andalon

View solution in original post

0 Kudos
4 Replies
255 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @EthanHP_Tsai,

Could you share the command used to enable the monitor mode?

BR,

Alexis Andalon

0 Kudos
241 Views
EthanHP_Tsai
Contributor II

Hi Alexis,

First, I use tcpdump to capture packet on mlan0, and I can't see any mDNS packet. When tcpdump start, mlan0 enter to promisc mode.

Then I try to write a simple socket program to bind udp port 5353 and 224.0.0.251, and mDNS packets are received. If I perform the command "ifconfig mlan0 promisc", can't see any mDNS packets.

I think I should be able to receive all packets when promisc mode is set.

Thanks,
Ethan

0 Kudos
217 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @EthanHP_Tsai,

Looking internally, the FP92 doesn't support the promisc mode. 

Sorry for the inconvenience this may cause you.

BR,

Alexis Andalon

0 Kudos
203 Views
EthanHP_Tsai
Contributor II

Hi Alexis,

Thanks for your clarification.

Ethan

0 Kudos