electromagnetic interferences problems

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

electromagnetic interferences problems

1,245 Views
sergemonnerat
Contributor III

Hi all,

We have many DC motors radiated electromagnetic interferences problems. The KL25 control board become a glitch factory when we increase the DC motor power. We tried all the possible solutions (filters, capacitors, etc...) but impossible to reduce the phenomenon. We put the control board at a distance of 50 cm without physical connections with the DC motors, then we supply the motors with an independent battery, result glitch! Does anyone has a miracle solution?

Best regards.

Serge

0 Kudos
6 Replies

767 Views
drummer
Contributor IV

I had a similar problem with my design. It was really sensitive to noise. I took it out to do emissions testing and found I was out of bounds in a few areas. The harmonic frequencies were based on my ethernet chip and my cpu clock. I respun the board and cleared any ground fills around the ethernet chip and the cpu. I also used ferrites to connect hi speed clock signals. I also deleted my development system header.

I wasn't thinking about my sensitivity as much as my emissions. The resulting design however solved both problems.

0 Kudos

767 Views
sergemonnerat
Contributor III

Hi Rick,

Thank you for the reply, our problems are the dc motors radiations, these motors are very bad and very cheap but we can not change it for the competition ... we will do with ...

Best regards

Serge

0 Kudos

767 Views
AndreSekulla
Contributor I

That was also one of our problems. We tried to reduce the glitches by filters, capacitors, etc..

and the rest of the glitches, we ignored by our software/algorithm (=> ignoring not correct "pictures" of the camera)

maybe, that could help you with this problem, too.

0 Kudos

767 Views
sergemonnerat
Contributor III

Hello Andre,

Thanks for your answer, we did the same as you... no miracles...

Best regards.

Serge

0 Kudos

767 Views
FlavioStiffan
NXP Employee
NXP Employee

Serge, did you test this with each motor individually or with both running at the same time?

0 Kudos

767 Views
sergemonnerat
Contributor III

Flavio, we did a lot of tests, with one motor, both, etc..., we even covered all the stuff with copper tape, nothing happens. We even had unwanted reset due to interferences... The only solution is to put here and there capacitors and to filter by software as necessary. It would be good for next year not to fight with this kind of problem ...

Best regards

Serge

0 Kudos