Unable to launch CodeWarrior after fresh install.

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to launch CodeWarrior after fresh install.

2,140 Views
bryantmorris
Contributor I

When CodeWarrior is launched, an error message pops up:

 

"The IDE failure to start suggests that the IDE COM components are not

registered properly. Run regservers.bat which is found in the same location

as the IDE.exe program to register the components"

 

After running "regservers.bat", this too fails with error "0x80020009" for

"MWComHelpers.dll", "MWRadModel.dll" and "CPlusSourceGen.dll" and

does not resolve the problem.

 

How can this problem be resolved?

Labels (1)
0 Kudos
3 Replies

157 Views
mardalianis
Contributor III

I had CWS12v5.2 and CW for microcontrollers V6.3 installed on my computer, and they were running normally. After a problem with the computer, I reinstalled Windows 10 (clean install) and the rest of the programs. Everything was running normally, except for the two above. The symptoms were as described in the first post (ie with the message for registering the components). The situation did not change by running "regservers.bat" in the way you suggested above. Removing and reinstalling the program did not eliminate the problem and at one point and then the program crashed almost immediately without any message. I transferred the downloaded program and installed it for testing on another computer and it worked normally. Then I got the following from Computer Management:

 

Log Name: Application

Source: Application Error

Date: 21/9/2021 1:22:55 pm

Event ID: 1000

Task Category: (100)

Level: Error

Keywords: Classic

User: N / A

Computer: DESKTOP-7FQE9UE

Description:

Faulting application name: IDE.exe, version: 5.9.0.5294, time stamp: 0x4c5ad4ea

Faulting module name: LMGR11.dll, version: 0.0.0.0, time stamp: 0x48287602

Exception code: 0xc000000d

Fault offset: 0x0007f841

Faulting process id: 0xb7c

Faulting application start time: 0x01d7aed2a4681c9d

Faulting application path: C: \ Program Files (x86) \ Freescale \ CWS12v5.2 \ Bin \ IDE.exe

Faulting module path: C: \ Program Files (x86) \ Freescale \ CWS12v5.2 \ Bin \ LMGR11.dll

Report Id: d7626ed9-318d-4708-bb98-9de802228a40

Faulting package full name:

Faulting package-relative application ID:

Event Xml:

<Event xmlns = "http://schemas.microsoft.com/win/2004/08/events/event">

  <System>

    <Provider Name = "Application Error" />

    <EventID Qualifiers = "0"> 1000 </EventID>

    <Version> 0 </Version>

    <Level> 2 </Level>

    <Task> 100 </Task>

    <Opcode> 0 </Opcode>

    <Keywords> 0x80000000000000 </Keywords>

    <TimeCreated SystemTime = "2021-09-21T10: 22: 55.8428056Z" />

    <EventRecordID> 2724 </EventRecordID>

    <Correlation />

    <Execution ProcessID = "0" ThreadID = "0" />

    <Channel> Application </Channel>

    <Computer> DESKTOP-7FQE9UE </Computer>

    <Security />

  </System>

  <EventData>

    <Data> IDE.exe </Data>

    <Data> 5.9.0.5294 </Data>

    <Data> 4c5ad4ea </Data>

    <Data> LMGR11.dll </Data>

    <Data> 0.0.0.0 </Data>

    <Data> 48287602 </Data>

    <Data> c000000d </Data>

    <Data> 0007f841 </Data>

    <Data> b7c </Data>

    <Data> 01d7aed2a4681c9d </Data>

    <Data> C: \ Program Files (x86) \ Freescale \ CWS12v5.2 \ Bin \ IDE.exe </Data>

    <Data> C: \ Program Files (x86) \ Freescale \ CWS12v5.2 \ Bin \ LMGR11.dll </Data>

    <Data> d7626ed9-318d-4708-bb98-9de802228a40 </Data>

    <Data>

    </Data>

    <Data>

    </Data>

  </EventData>

</Event>

Is there a solution to this?

0 Kudos

654 Views
trytohelp
NXP Employee
NXP Employee

Hi Bryant,

I think I've worked on same problem some weeks ago.

I've planned to create a doc for that.

++++++++++++++++++++++++++++++

Get “IDE failed to start …” message

  1. A- Description

In some case after to have installed Classic version, you could meet an error when you launch the IDE.

pastedImage_0.png

  Most of the time the error is introduced because the IDE is not correctly registered.

As suggested by the message we need to execute the \bin\regservers.bat file.

This will initialize correctly the dlls used by the IDE.

In some case, most of the time under 64 bit OS (Win 7 and Win 8), the \bin\regservers.bat generates some errors:

pastedImage_3.png

 

  1. B- Solution

To solve the problem we need to execute the \bin\regservers.bat file via a Command Prompt running as Administrator mode.

pastedImage_6.png

Now we can launch the IDE

pastedImage_8.png

Attached a video too.


Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

654 Views
TICS_Fiona
NXP Employee
NXP Employee

There should be some problem with the CodeWarrior  install.

Please :
         - un-install the tool completely,
         - remove the install folder,
         - re-install the tool,
         - execute the Regserver.bat file.

If this does not work, please reply with the CodeWarrior version you are using.

For Classic CodeWarrior IDE, please:
         Start the IDE and click on Help | About Freescale CodeWarrior.
         Click on Installed Products
         Provide us all info displayed.
         Or you can save them in a txt file.


For Eclipse CodeWarrior IDE, please: 
     1-  Start Eclipse and click on Help ¦ Freescale Licenses
         The Status column gives the status of the license.
         Under Product, select it and click on details.
         A new dialog show up giving license details.
         Provide us all info displayed
     2-  Start Eclipse and click on Help ¦ About CodeWarrior Development Studio
         Under Installed Products, you will see the version used.

What it the OS on your PC? Is it 32bit, or 64bit system?

Fiona Kuang

Technical Information & Commercial Support

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos