S32K344 + FreeRTOS + Segger Debugger

Showing results for 
Show  only  | Search instead for 
Did you mean: 

S32K344 + FreeRTOS + Segger Debugger

Contributor III

So here's the situation:

We are creating our own boards with the S32K344 MCU. We want to use the Segger debugger (because there aren't really any other options for DIY), and we will also be using FreeRTOS. 

So far we've been developing with the devkits which have the PNE Micro debugger. Everything always worked, FreeRTOS ran no problems, all the RTD drivers we've been using also run no problem. 

We got out custom boards, and decided to upload some test firmware to it using the debugger. We uploaded code without FreeRTOS no problem, everything works.

However, when we tried to run firmware which used FreeRTOS (and had been known to work using the PNE Micro debugger on a dev kit), we ran into a bit of an issue. 

The code runs up to where FreeRTOS starts the first task, and then gets stuck in the svc 0 instruction in the picture shown below


Now at first we thought it was our hardware, so we ran it on a dev kit using the Segger J link debugger and the same problem happened. We looked online for answers and it says it has something to do with an interrupt vector, but it also says that this already comes with the port of FreeRTOS that NXP has made for the S32K344.

Please if anybody knows what this issue is, or why this is happening, and how we could possibly solve this it would be very appreaciated. 

We are literally stuck because we can't run any of our firmware on the custom hardware we built.

I didn't link any projects because this also happens even with the FreeRTOS examples included in S32DS. Below if the software versions of all our stuff.


The Segger version is V7.60f

Thanks in advance for the help!



0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

Hi Mateo,

could you please forward this to Segger? Most likely, this issue is caused by their plugin.



0 Kudos