Rappid tool for S32K144

cancel
Showing results for 
Search instead for 
Did you mean: 

Rappid tool for S32K144

2,331 Views
ambarishhundeka
Contributor III

Hi Nxp Team,

I have gone through the user manual of RAPPID tool and fallowed the below steps 

1. Drag and drop the RBF file o the Evaluvation board

2.reset the EVAL board(connected the S32K144 Eval board with USB)

3. open the Rappid tool 

4.load the rbl file (given in the example project of S32K_bootloader ,edited the path in the rbl file) 

5. tool updated the all the configuration details and  click  on the "start the bootloader"

but it is not programmed , it is showing error "loss communication with CCP MCU, please cycle power and try again" and "operation has timed out".

I have tried with reset the controller and tried , but still getting same error.

for the application download also, manually i have set the configuration details and and disable the "BAM status" ,  tried to flash the Timer_test.hex file ,still it is showing same error.

find the attached errors images and please let me know the solution.

Regards,

Ambarish

Labels (1)
Tags (2)
8 Replies

957 Views
stanish
NXP Employee
NXP Employee

Hello,

I'd recommend you to generate srecord file image instead of intel Hex.

RAppID bootloader supports just s19 record (srec) file format.

Hope it helps.

Stan

0 Kudos

957 Views
ambarishhundeka
Contributor III

Hello Stanish,

Thank you for your immediate response.

I have tried with S19 file also , still getting same error.

do I need to changes any settings in eval board(jumper connection change)?

I fallowed the steps explained in the forum by Jiri.Kral.

link is here :

https://community.nxp.com/thread/464653.

even for example code , getting the same error.

for the application flashing :

we can manually set the port configuration , disable the BAM , and tick the "erase and program"  and start the bootloader.

is this correct

Thank you in advance for your help.

Regards,

Ambarish

0 Kudos

957 Views
marcopunzi
Contributor I

Hello Ambarish,

Any solutions? I have your same problem.

Regards,

Marco

0 Kudos

957 Views
ambarishhundeka
Contributor III

Hello,

 please try with other rbf file.

I forget the link. I can send you the rdf file if you want.

Regards,

Ambarish

0 Kudos

565 Views
nishalemos
Contributor II

@ambarishhundeka 

I am even facing the same issue.

If you have resolved it could you please guide me.

I have uploaded the RBF file provided in MATLAB toolbox for UART0  CAN0.(with S32k144)

Baud Rate :115200.

But I always get Loss of Communication CPP Error.

 

Regards 

Nisha Lemos 

0 Kudos

957 Views
danielbernert
Contributor I

Hi,

Could you provide me this file also? I have the same Problem.

Thank you.

Greetings 

0 Kudos

957 Views
marcopunzi
Contributor I

It would be great!

Which version of the RAppID have you used with it?

Thank you in advance Ambarish!

Regards,

Marco

0 Kudos

596 Views
rathi_tg
Contributor III

@marcopunzi 

 

Hello is your Boot loading working?

I always get a CPP Error 

Regards 

Gopal Rathi

0 Kudos