OpenSDA s32k144evb Linux Ubuntu 20.04 port not found

表示  限定  | 次の代わりに検索 

OpenSDA s32k144evb Linux Ubuntu 20.04 port not found

Contributor I

S32 IDE for ARM can't detect Open SDA port in settings. I've installed libusb driver from PEMicro, but nothing was changed.

DMESG output:

[  489.635911] FAT-fs (sdc1): unable to read boot sector to mark fs as dirty
[  495.353667] usb 1-10: new full-speed USB device number 8 using xhci_hcd
[  495.503381] usb 1-10: New USB device found, idVendor=1357, idProduct=0089, bcdDevice= 8.00
[  495.503387] usb 1-10: New USB device strings: Mfr=1, Product=3, SerialNumber=5
[  495.503390] usb 1-10: Product: OpenSDA Hardware
[  495.503394] usb 1-10: Manufacturer: P&E Microcomputer Systems Inc.
[  495.503396] usb 1-10: SerialNumber: SDA8721CE0E
[  495.509318] cdc_acm 1-10:1.0: ttyACM0: USB ACM device
[  495.510367] usb-storage 1-10:1.3: USB Mass Storage device detected
[  495.510660] scsi host6: usb-storage 1-10:1.3
[  496.530062] scsi 6:0:0:0: Direct-Access     FSL      FSL/PEMICRO MSD  0001 PQ: 0 ANSI: 4
[  496.530287] sd 6:0:0:0: Attached scsi generic sg2 type 0
[  496.530683] sd 6:0:0:0: [sdc] 1983999 512-byte logical blocks: (1.02 GB/969 MiB)
[  496.530826] sd 6:0:0:0: [sdc] Write Protect is off
[  496.530828] sd 6:0:0:0: [sdc] Mode Sense: 00 00 00 00
[  496.530994] sd 6:0:0:0: [sdc] Asking for cache data failed
[  496.530997] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  496.571612]  sdc: sdc1
[  496.582750] sd 6:0:0:0: [sdc] Attached SCSI removable disk

Output of PE console:

sudo ./pegdbserver_console -showhardware

P&E GDB Server for Arm(R) devices, Version
Copyright 2018, P&E Microcomputer Systems Inc, All rights reserved

Loading library /home/alex/Applications/NXP/eclipse/plugins/com.pemicro.debug.gdbjtag.pne_4.4.6.201912192052/lin/gdi/ ... Done.

Command line arguments: -showhardware


What's wrong with it?

0 件の賞賛
5 返答(返信)

Contributor II


For me this turned out to be a path, or 64b vs 32b issue: P&E has an installation script that copies the USB driver to /usr/lib64 if the folder exists. Instead, I tried copying the driver to /usr/lib. After refreshing the ports in S32DS, it appears! Like magic! The driver file is the "" available at ~/NXP/S32DS.3.4/Drivers/PnE/drivers/libusb_64_32/.

I think it is worth mentioning that initially the arm-none-eabi-gdb refused to work for lack of a
(I only found this out when tracking down and running the software in ~/NXP/S32DS.3.4/S32DS/tools/gdb-arm/arm32-eabi/bin, Eclipse would just throw a dumb error.)
The solution was to create a symbolic link from to under /usr/lib/x86_64-linux-gnu, as in the answer below:

Also, NXP devboards have very dodgy tactile switches! I couldn't enter BOOTLOADER mode in OpenSDA because SW5 just won't close contact! At least 2 of the 4 on the board are broken.

Also worth checking if your board is somewhat older (didn't work for me, because of the above):

[This is the second attempt at posting, first I spent some 20 minutes writing the answer, just to get it thrown away because I was redirected to login after clicking post. Thanks NXP, just one more frustration among so many.]

Contributor III

Guess what? This did the trick. Thanks a lot for sharing!


0 件の賞賛

Contributor II

Worked like magic !!



0 件の賞賛

Contributor II

I am facing the same issue as well. Do you know when it will be supported ?

0 件の賞賛

NXP Employee
NXP Employee


unfortunately - Ubuntu 20.04 is not supported by S32DS. You can try to install PE Micro drivers manually 

 PEmicro | Experts in Embedded tools for Flash Programming and Development  

Officially supported and tested Ubuntu version is Ubuntu 16.04 LTS. On ubuntu 18.04 S32DS also works (but is not tested).


0 件の賞賛