No more debug connection after Port-Cfg.

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

No more debug connection after Port-Cfg.

374 次查看
BenjaminKubitschek
Contributor I

By trying out a binary I set up for S32K358 (On S32K3x8CVB-Q289) and another one for S32K344 (on the S32K3XXEVB-Q172) I got to the same problem:

Durring startup phase I suddenly lost debug-connection, and havent been able to get the connection back since then. The error appeared after the Port_Init() (Port-Module of the AUTOSAR-Stack):

After writing with the support-team of the debugger (iSystem), it seems like that the Port-Module reconfigured the JTAG-Pins of the controller, so that the jtag functionallity is no longer present.

Now the question is, am I able to get the debugger connetion back somehow on the the chips? Is there a way to reset the port-config without a debug-connection?

I wrote about this with one of the NXP-Engeneers, who recommended to open a question here.

 

0 项奖励
1 回复

360 次查看
danielmartynek
NXP TechSupport
NXP TechSupport

Hello @BenjaminKubitschek,

I assume the reset_b pin is reconfigured to another function too, otherwise the debugger should be able to reset the MCU and establish connection.

The JTAG/SWD/Reset_b pins are set to their default JTAG/SWD/Reset_b functions after each system reset.

The debugger can use it until it is reconfigured by the application SW.

So, you should be able to connect the debugger within this short time window.

If the reset_b pin is also reconfigured, you can power-cycle the MCU to reset it.

 

Something similar was discussed here (S32K144):

https://community.nxp.com/t5/S32K/S32K144-EVB-got-corrupted-after-Running-a-SDK-based-project/m-p/16...

As mentioned in the thread, PE Micro have an utility for this.

 

With Lauterbach, we can use a script like this

system.CPU S32K344
wait state.power()
system.attach

 

Somewhat related thread is below (S32K312).

The MCU was erased using J-link commander:

https://community.nxp.com/t5/S32-SDK/failed-to-power-up-dap-after-program-s32k312-with-pll0-equal/td...

 

Unfortunately, I'm not aware of any solution using iSystem.

I believe iSystem support should be able to help you with this.

 

Regards,

Daniel