gcc v10.2 in S32DS for S32 platform v3.4 doesn't have gdb util

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

gcc v10.2 in S32DS for S32 platform v3.4 doesn't have gdb util

ソリューションへジャンプ
1,591件の閲覧回数
wesleyxie
Contributor III

Hi, NXP

I created a S32K312 project in S32DS v3.4, and select "NXP Gcc 10.2 for Arm 32-bit Bare-Metal" as the toolchain, since I want to use RTD SDK v2.0.1 (if I select Gcc 9.2, RTD SDK v2.0.1 is disappeared from the  SDK list).

the project successfully to compile, but below problem occurred when I tried to debug, it seems S32DS can not find gdb util. so I check the bin folder of gcc v10.2 of the S32DS install path, the gdb util is missed. but for gcc v9.2, the gdb util is present.

how to solve this issue if I want to use RTD SDK v2.0.1 for S32K312 ? 

thanks and best regard.

wesleyxie_0-1664793046694.png

wesleyxie_1-1664793107356.png

 

0 件の賞賛
1 解決策
1,502件の閲覧回数
mikedoidge
NXP Employee
NXP Employee

Hello @wesleyxie 

Apologies for the long delay. I noticed in your screen shot, in the GDB Client Setup section, you have:

D:\NXP\S32DS.3.4\S32DS\build_tools\gcc_v9.2\gcc-9.2-arm32-eabi\bin

This is a problem because your project is set to use GCC v10.2. The SDK only supports GCC v10.2, so you should set the path for the GCC v10.2. If you like, you can use a macro that is pre-defined:

${S32DS_GDB_ARM32_EXE}

This way you can avoid using a hard-coded path for this project. Please change the setting to this value and try again. 

Best Regards,

Mike

元の投稿で解決策を見る

0 件の賞賛
4 返答(返信)
1,503件の閲覧回数
mikedoidge
NXP Employee
NXP Employee

Hello @wesleyxie 

Apologies for the long delay. I noticed in your screen shot, in the GDB Client Setup section, you have:

D:\NXP\S32DS.3.4\S32DS\build_tools\gcc_v9.2\gcc-9.2-arm32-eabi\bin

This is a problem because your project is set to use GCC v10.2. The SDK only supports GCC v10.2, so you should set the path for the GCC v10.2. If you like, you can use a macro that is pre-defined:

${S32DS_GDB_ARM32_EXE}

This way you can avoid using a hard-coded path for this project. Please change the setting to this value and try again. 

Best Regards,

Mike

0 件の賞賛
1,488件の閲覧回数
wesleyxie
Contributor III

hi, @mikedoidge

sorry, i took a wrong screenshot last time, I was trying to use gdb client in  "gcc_v9.2".

I modified the "Executable" path of "GDB Client Setup" section to your solution (${S32DS_GDB_ARM32_EXE}), and it works.

by the way, if i restore "Debugger" tab to default, the executable path is "${cross_prefix}gdb${cross_suffix}", it doesn't work.

wesleyxie_0-1666319662720.png

 

0 件の賞賛
1,574件の閲覧回数
mikedoidge
NXP Employee
NXP Employee

Hello Wesley,

Please provide a screen capture of the Debug Configuration, Debugger tab. It will show if the settings are correct. It's possible the path to the GDB server is incorrect. Also, if you could turn on the log file:

mikedoidge_0-1664975378048.png

 

And enable the GDB Traces log from Window -> Preferences:

mikedoidge_1-1664975449401.png

The log for this is shown in the console, you will need to select the GDB traces option.

If you could send both logs, this will also help.

Best Regards,

Mike

0 件の賞賛
1,556件の閲覧回数
wesleyxie
Contributor III

Hi, mike

please check the screenshot of my Debugger tab below.

wesleyxie_0-1665213417309.png

wesleyxie_3-1665213862464.png

 

"Also, if you could turn on the log file:"

wesleyxie_1-1665213653300.png

--- I can't find this option

"And enable the GDB Traces log from Window -> Preferences:"

-- done

 

0 件の賞賛