S32DS_ARM_Linux_v2018.R1.bin installation failure on Ubuntu 20.04

cancel
Showing results for 
Search instead for 
Did you mean: 

S32DS_ARM_Linux_v2018.R1.bin installation failure on Ubuntu 20.04

420 Views
choppe
Contributor I

I am trying to install S32DS_ARM_Linux_v2018.R1.bin on Ubuntu 20.04

My Java version is

openjdk version "1.8.0_292"
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0ubuntu1~20.04-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

The installation fails right after entering Activation code.

Error message is in the log ( log attached here )

Please help!

 

0 Kudos
4 Replies

117 Views
MichaelBMiner
Contributor III

Following the attached PDF, this works perfectly on Ubuntu 20.04. I am running in virtual box just to automate a build. 

 

0 Kudos

345 Views
choppe
Contributor I

@jiri_kral 

I have installed following required libraries

apt-get install make build-essential lib32ncurses6 libc6-i386

Is there anything else which needs to be installed ? Firewall setting seems to be fine. As per to logs the exception happens in 

# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f5ae8aedfd2, pid=97585, tid=0x00007f5b0fbca700
#
# JRE version: OpenJDK Runtime Environment (8.0_292-b10) (build 1.8.0_292-8u292-b10-0ubuntu1~20.04-b10)
# Java VM: OpenJDK 64-Bit Server VM (25.292-b10 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libcll_app_libFNP.so+0x854fd2]

do you have any visibility on what might have caused this ?

0 Kudos

316 Views
mikedoidge
NXP Employee
NXP Employee

Hello @choppe ,

I noticed that the install guide for this version is not available on the website. I've attached it to this reply, 'arm_pdf_getting_started.pdf'. Please check that you follow the instructions for 'Installation prerequisites for Linux platform'. I will also point out that Ubuntu versions 14 and 16 are supported by this release. Since you are using version 20.04 we cannot confirm it will work without issue. I've also attached the release notes, 'Release_Notes.pdf', for more details on this version.

For best results, it is recommended to use one of the versions of Ubuntu listed as supported in the two attached documents.

Hope it helps,

Mike

0 Kudos

357 Views
jiri_kral
NXP Employee
NXP Employee

Hi,

 

Ubuntu 20.04 is not officially supported by S32DS ARM v2018.R1. The supported version is Ubuntu 16.04 and it is also possible install it on Ubuntu 18.04, but I never tried install it on Ubuntu 20.04. 

 Did you installed all required 32 bit libraries? What about firewall settings? 

 

Jiri

0 Kudos